USB Wifi error No DHCPOFFERS received


I have a D-Link N300 (Realtek RTL8196E) that I connect to a pynq-z1. I tried with images 2.4 and 2.5. The wifi dongle is recognized as I can see it with lsusb, however, when I want to connect to my network, I always get the following.

xilinx@pynq:~/pynq$ sudo python3
Python 3.6.5 (default, Apr  1 2018, 05:46:30)
[GCC 7.3.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> from lib import Wifi
>>> port = Wifi()
>>> port.connect('MYSSID','PASSWORD')
ifdown: interface wlan0 not configured
Internet Systems Consortium DHCP Client 4.3.5
Copyright 2004-2016 Internet Systems Consortium.
All rights reserved.
For info, please visit

Listening on LPF/wlan0/80:26:89:73:28:ea
Sending on   LPF/wlan0/80:26:89:73:28:ea
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to port 67 interval 3 (xid=0x3605b91b)
DHCPDISCOVER on wlan0 to port 67 interval 4 (xid=0x3605b91b)
DHCPDISCOVER on wlan0 to port 67 interval 4 (xid=0x3605b91b)
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

I tried even on different networks, with a router and using two mobile phones as hotspots. The problem remains.
I even read that I should use a Logilink WL0084E (Realtek RTL8188EUS) but that is not even recognized when plugged.

Anyone knows what could be the problem?
Thank you

This is a problematic USB dongle. We found that additional kernel configurations have to be enabled in order to use this dongle. Is it possible for you to try a different USB wifi module, e.g. the raspberry pi wifi dongle?

Thank you @rock for the answer. It should be one with a Ralink 5370 chipset, right? I could get a LogiLink WL0084E, would that work? It has the same chipset as the one you suggested.

I don’t know whether it will work, but if the chipset is the same as Ralink 5370, it should work. Some relevant discussion here.

I am having some trouble finding the one that you suggests to buy in Europe. Besides that, let’s say I find it or I try another with the same chipset (Ralink 5370). The fact that I have the Z1 shouldn’t be a problem, right?

Z1 should be OK.