"No devices found, XRT environment sourced?" Error

Hi there,

I think you should be using absolute paths in your make command, looks like the makefile can’t find relative path of enclustra/xu1_2020

Thanks
Shawn

@skalade

using absolute path solved many issues, thanks!! I encountered a few small issues when doing a make with pre-built aarch64 image, making the build fail before the STAGE4 packages were added. I could solve these and now I can build an image. At the end the make script fails with the errors below. Still I see an image file and I will test this image tomorrow, @slalade @marioruiz do you have an idea of what is wrong with my build based on errors below?

INFO: The image(s) were created using OE kickstart file:
/home/rootuser/pynq/PYNQ/sdbuild/boot/image.wks
Num Start End Size Fstype
1 4096 136318975 136314880 fat16
2 137363456 9372664831 9235301376 ext4
mkdir -p /home/rootuser/pynq/PYNQ/sdbuild/output/dist
mkdir -p /home/rootuser/pynq/PYNQ/sdbuild/output/dist/aarch64
cp -rf /home/rootuser/pynq/PYNQ/sdbuild/build/PYNQ/dist/.tar.gz /home/rootuser/
pynq/PYNQ/sdbuild/output/dist/aarch64
cp: cannot stat '/home/rootuser/pynq/PYNQ/sdbuild/build/PYNQ/dist/
.tar.gz’: No
such file or directory
Makefile:344: recipe for target ‘/home/rootuser/pynq/PYNQ/sdbuild/output/dist/aa
rch64’ failed
make: *** [/home/rootuser/pynq/PYNQ/sdbuild/output/dist/aarch64] Error 1

Despite stopping with a build error, the pynq 2.7 build seems to functioning correct. So I assume I can ignore this error. @skalade

Hi there,

You’re probably fine if the image is working, it seems like it was trying to copy a dist tarball to the outputs which didn’t have a name for some reason.

I can’t tell why this would’ve happened, maybe some env variable wasn’t set correctly… We could get a bit more insight if you shared the full log, including your exact make command.

Thanks
Shawn

1 Like

Hello,

I am facing the same issue. I bought a PYNQ Z2 board with an included SD card from TUL. I updated the PYNQ version from 2.5 to 2.7 using the instructions on the repo, and the same error message appears when I try to create an overlay in a notebook. Is there any way to fix this?

Thanks.

EDIT: Downgrading to 2.5.4 fixed this. Is there any way to keep using 2.7 without having to rebuild/reprogram the SD card externally? I don’t have an Ubuntu environment handy and installing an entire VM for this would be a chore.

Hi @plasmidon,

There are pre-built images here, just download, burn the SD card and start using PYNQ.

Mario