Building ZCU216 image with newer PYNQ 3.0

Hi everyone,

I am new to PYNQ and tried to build an image for the ZCU216 with the supported files by sarafs on Github (GitHub - sarafs1926/ZCU216-PYNQ: Board repo for the ZCU216 RFSOC. I wanted to use the newest PYNQ 3.0.0 version (with associated Vivado and Petalinux version) instead recommended PYNQ 2.7. As you can think off, this failed the first time. When actualizing the used tool version variables in the makefile and spec file, it worked for about 45 min and a boot image could be generated, but then this messages appeared:

WARNING: Unable to access the TFTPBOOT folder!!!
WARNING: Skip file copy to TFTPBOOT folder!!!

after that mkimage failed and complained that a file called “boot.cmd.default” can’t be located.
Now I have following questions:

  1. Is the generated boot image usable or just an useless artifact?

  2. Would it have worked if I had strictly used PYNQ 2.7?

  3. Could this problem still be fixed by changing version variables in makefile and specs or would it be easier to deinstall all Xilinx tools and reinstall the older versions recommended for PYNQ 2.7?

I attached a screenshot of the terminal for better comprehension at the end.

I t would be amazing if you could help me.

Best Patrick

1 Like