PYNQ: PYTHON PRODUCTIVITY

Disable Chromium at boot up

Is there any way to disable the chromium at starting up? I am using zcu104 running PYNQ 2.5. I don’t want to start the os if display port is connected.

Thanks.

Chromium is started by the script /root/.fluxbox/startup. You can remove the call to Chromium there

Peter

Thank you Peter. I have disabled the chromium. But displayport output still shows the linux starting text and the kernel. Is there any way to completely blackout the DisplayPort Out without showing any text there?

Do you want the DisplayPort to be available at all? What’s the end result you are after?

If you want to disable the DIsplayPort altogether you can just disable it in the device tree. If you want access to it from PYNQ but not to be used anywhere else that’s a more generic Linux boot configuration setting that I don’t know the answer to.

Peter

1 Like

I was actually trying to do the latter one

If you want access to it from PYNQ but not to be used anywhere

Also, I am still stuck with the problem of running a program without connecting to the DisplayPort connection. I wanted to do a timeout/any workaround if dp connection is not available. Even though I have a workaround for HDMI But unfortunately I couldn’t find any solution for DisplayPort. The program just quit if connection is not there.

That’s a limitation in our implementation unfortunately. I’ll add it to the list of things to look at for the next release. The DisplayPort class has a modes attribute you can use to both see if a monitor is connected and if it supports the resolution you want to use. It’ll be empty if there is no monitor is connected or something else has gone wrong otherwise it’ll be a list of VideoMode objects that are supported by the display. Excuse the for/else notation I’ve used for brevity, I hope it gets the idea across.

mode = VideoMode(1280, 720, 24)
displayport = DisplayPort()
for m in displayport.modes:
    if m.width == mode.width and m.height == mode.height
        displayport.configure(mode, PIXEL_RGB)
        break
else:
    print("Monitor not connected or doesn't support resolution")
1 Like

I already have tried this one. But it doesn’t work. If I run this on jupyter, the kernel died. If I run from kernel as python program, dump out and exit.

That’s weird - it’s working on my ZCU104 and 2.6 image. Can you post the contents of the error you are seeing when you run the code on the command line?

Peter

You need to remove the configure on line 5

1 Like

Thank you very much. I can’t express enough gratitude. It is already been more than two months, I am stuck at this point. It worked though the print command is not running in both jupyter and kernel. But I don’t need that.
Thanks a lot.