DPU load model error

I am working with Ubuntu image 20.04 for Kria Starter board.

The sample Jupyter notebooks in the pynq-dpu folder work fine with dpu_resnet50.xmodel. I tried changing the model by changing the argument in the overlay.load_model() function to mobilenetv3.

This resulted in the following error, when executing. I did recompile the mobilenet model using the arch.json file for KV260 board.

File “/usr/local/share/pynq-venv/lib/python3.8/site-packages/pynq_dpu/dpu.py”, line 171, in load_model
assert len(subgraphs) == 1


I first tried using the downloaded .xmodel from the link mentioned in the model.yaml. When this did not work, I tried compiling it using the arch.json for KV260 and tf2 quantized (.h5) model.

Hi there,

I think the reason for this is because you are downloading from the master branch of Vitis AI (where VART version is 2.0), DPU-PYNQ is still currently on v1.4 and that causes some model incompatibilities.

You could download mobilenetv2 from the v1.4 branch instead and that should work without issue, no need for re-compilation.


The incoherency in VART (2.0) and DPU-PYNQ (1.4) versions was causing this. It works now!

Thank you.