Gordian knot @make: gcc-multilib vs. gcc-arm-linux-gnueabihf

I’ve tried to make an image for a Zed-Board under Ubuntu 18.04 with Xilinx 2020.1 versions:
The flow , respectively parts of it seem to require
gcc-multilib and
but they are mutually exclusive: Installing one of them uninstalls the other.
I have searched at lot for a remedy but did not find any that worked.
So how can I solve this issue?

Forgot the actual error message:
make[1]: Entering directory ‘/home/datatel/Petalinux/dt7xxx_Zynq_Zed_Petalinux/PYNQ/sdbuild/build/gcc-mb’
[INFO ] Performing some trivial sanity checks
[WARN ] Number of open files 1024 may not be sufficient to build the toolchain; increasing to 2048
[INFO ] Build started 20210701.135827
[INFO ] Building environment variables
[ERROR] Missing: ‘arm-unknown-linux-gnueabihf-ar’ or ‘arm-unknown-linux-gnueabihf-ar’ or ‘ar’ : either needed!
[ERROR] >>
[ERROR] >> Build failed in step ‘(top-level)’
[ERROR] >>
[ERROR] >> Error happened in: CT_Abort[scripts/functions@487]
[ERROR] >> called from: main[scripts/crosstool-NG.sh@472]

Hi vnick,
I am currently trying to deal with the same problem. Did you solved this? If yes , could you please explain how?


Hi Vnick and Emcyhn, hope you’re doing well.
I’m using Ubuntu 18.04 in a VMware workstation. The Xilinx tools are the 2020.2 as well as the PetaLinux version. At first, I had the same problem when running make BOARDS=Pynq-Z1. This problem was solved by following this: PYNQ 2.5 ct-ng build error. For instance, I went to ~/PYNQ/sdcard/build/ and remove the gcc-mb folder. After that, I run make BOARDS=Pynq-Z1.
However, the crosstool-ng uses broken links to the libisl and expat. To correct that I used: Resolving download issues (e.g isl-0.20, expat-2.2.6) · Issue #1625 · crosstool-ng/crosstool-ng · GitHub. Specifically, I edited the libisl and expat mirrors in /opt/crosstool-ng/share/crosstool-ng/config/versions/isl.in and expat.in, and /opt/crosstool-ng/share/crosstool-ng/packages/isl/packages.desc and /opt/crosstool-ng/share/crosstool-ng/packages/expat/packages.desc. Then remove the gcc-mb and run make again. With this changes the compilation process continued.
Hope it can be useful.
Dorfell :slight_smile:

1 Like

The issue with ISL has also been mentioned here: Pynq Compilation isl: download fail and here: Cannot build PYNQ2.7 because isl.gforge.inria site is shut down - #2 by bierkof