Kernel crash kernel panic

i have the exact same problem

steps to repro duce:

  1. download sdcard image from site
  2. unzip write to sdcard using dd if=filename.img of=/dev/sdb
    3 insert card and power up

using same card that came with pynq-z1 board

Hi there,

Have you tried burning the image a few times and it is consistently happening, or have you only tried once?
Have you tried using a different SD Card writer to burn the image?
Do you have another SD Card that you can try?

All the best,

Two different cards
I have only 1 sd card writer

Also - understand that another person reported the exact same issue
See: Kernel panic - PYNQ Z1

Thus - 2 independent cards, 2 independent(different) reader/writer hardware
The other reporter states they used a windows tool to write
I am using “dd if=img of=/dev/sdb” on my linux box

UNKNOWN: if anything changed for the other reporter.

If you think there is a problem with the procedure please give a complete Linux based procedure to replicate.

If you think it is a hardware issue, explain where in the data chain the problem might have gone bad? I mean the USB has a crc16 on the data as it is transferred, the SDCARD uses a CRC16 on each of the 4 data lines when writing and when reading, - so unless the SDCARD CRC1 has failed something else is going on, I would like to know what you think would have failed?

And - why do I not see any problems when writing a Raspberry PI sd card using the same SDCARD writer? (different card) One would think that if the reader/electronics is bad for card (A) it would also be bad for card(B) - or one would see random failures across both cards, both systems

What size is your sd card?

Looking at the log from your other post, these lines:

mmcblk0: p2 size 15604212 extends beyond EOD, truncated
No soundcards found.
cfg80211: failed to load regulatory.db
EXT4-fs (mmcblk0p2): bad geometry: block count 1950526 exceeds size of device (1932544 blocks)
EXT4-fs (mmcblk0p2): bad geometry: block count 1950526 exceeds size of device (1932544 blocks)

seem to indicate you might be running out of memory on your rootfs partition. If that is the case I’d recommend trying a bigger sd card.


Ok - so the image is 7.6G - silly me - I thought that it would fit… on an 8GIG card!
I have several 8 gig cards

Bigger problem:
The PYNQ-Z1 - SHIPS with an 8gig card!
This means the anyone who purchases a PYNQ-Z1 will hit this problem.
And they will not know what the problem is

 The users will assume the card that came with the Z1 is the correct card to use
 But - evidently it is not a viable card to use!

Perhaps you should inform DIGILENT that they need to swap out the SD CARD in all of their shipping product and change to a 16gig card

I am sure the production stock (think: All the Z1 boards at Digikey, at Mouser, Element14, etc) - not to mention the Z2 boards and other boards - not sure if they ship with an SDCARD present or not! That entire distribution/supply pipe line is full of SD CARDS that will not work. This will cause no end of people grief and problems.

I’ll go get a 32gig card, I have run into this problem before - you buy an SDCARD that is of size (X) - and in reality it is much smaller by some percentage and the image does not fit!

The RASPBERRY PI group have a wonderful solution for this -

the distribution SDCARD image they create is very tiny and only large enough to hold the files they require. This makes their SD CARD image UNIVERSAL!

Step1 : the R-PI end-user(aka:victim) writes the SD Image to the SDCARD any SD CARD

Step2 : insert and boot - you will notice there is a message about the SDCARD * that is when the magic is happening! You should clone this magic! *

Step 3 : What is happening is the RPI examines the actual SD CARD then auto-expands the file system to fit the actual card in the machine

Ask your self - do you really have 8GIG of stuff on that SDCARD image?
Or - did you make the SDCARD this big so. you have plenty of room later?

Note: Why do I suggest you contact Digilent and let them know what they ship will not work.

If I was to do that and goto their Web Site and click on their “Support Link” for their product - it comes back to this site - so they do not support this product, they only build and ship the board

I bet you have a better contact with them then I would have and probably would have better luck informing them of this issue (the card they include/ship with the product) no longer is functional and needs to be 16gig!

Well as you might know PYNQ is a rolling project and with each new release the size of the sd card image can increase due to new feature additions/new packages/upgrades/etc. We are mindful of the 8GB threshold, but I suppose it is approaching, especially when these types of sd cards have a variance to them. The solution could be to reduce image size, but will have to look into it.


UPDATE _ FIXED - I purchased a 10 pack of 32GIG microSD cards -
these work great, the problem I had before has gone away.

Thus I would suggest on your DOWNLOAD page - at least tell people to use 16gig cards (and specifically do not use 8gig cards)

That alone would have stopped my problems in their tracks.