PYNQ: PYTHON PRODUCTIVITY

Pynq SD card boot error (prebuilt_image using BSP)

Hi,

Pynq git version: master
Ubuntu version: 18.04.6 LTS
Vivado version: 2020.1
Petalinux version: 2020.1

I am using the above-mentioned versions to build Pynq overlay using the prebuilt image command. Using BSP file, which is built using petalinux 2020.1

Using coustom Ultrscale+ board (part xczu4ev-sfvc784-1-i )

Command to build Pynq Image: bash scriptpts/image_from_prebuilt.sh Boardname Boards.bsp aarch64 bionic.aarch64.2.6.0_2020_10_19.img

I successfully generated the image file, when I write this image file to sd-card using windisk manager boot it in custom FPGA board I get the following error:

–end kernel panic -not syncing : VFS: unable to mount root f-

Tried different ways mentioned to write image file but no luck, I tried just with BSP petalinux bootable file writing to SD card works fine.

Here attaching complete log log.txt (35.6 KB)

1 Like

I am thinking if there are any options I need to choose while generating the BSP file for PYNQ. I did keep everything default and built the project.

1 Like

Hi,

How big is your SD card and is it the only SD card you’ve tried? I also wonder if you could mount the root partition on your host machine as a sanity check just to see if you can actually access files there.

If it’s a write protection issue, a solution to a similar problem has been shown in this forum post, you might be able to make this addition to your system-user.dtsi in your petalinux project.

Shawn

3 Likes

Yes thank you, you guessed it right it was a problem with the write protection issue. Where as this issue encounters while building for a custom board. The forum post was helpful. Along with that, I made a few other changes that worked fine in the end.

1 Like