PYNQ: PYTHON PRODUCTIVITY FOR ZYNQ

No incoming video signal detected ; Pynq Z1

I have a GoPro camera connected to the Pynq Z1 at 720p, 30 fps, when I try and run the notebook : /notebooks/capture_hdmi_display_notebook_hdmi.ipynb , I get this error :
LookupError Traceback (most recent call last)
in ()
6 hdmi_in = base.video.hdmi_in
7 print(‘Success’)
----> 8 hdmi_in.configure()
9 hdmi_out.configure(hdmi_in.mode)

/usr/local/lib/python3.6/dist-packages/pynq/lib/video/hierarchies.py in configure(self, pixelformat)
106 self._color.colorspace = pixelformat.in_color
107 self._pixel.bits_per_pixel = pixelformat.bits_per_pixel
–> 108 self._hdmi.start()
109 input_mode = self._hdmi.mode
110 self._vdma.readchannel.mode = VideoMode(input_mode.width,

/usr/local/lib/python3.6/dist-packages/pynq/lib/video/dvi.py in start(self, init_timeout)
77 self._capture = pynq.lib._video._capture(gpio_dict,
78 vtc_capture_addr,
—> 79 init_timeout)
80
81 def stop(self):

LookupError: _video._capture initialization failed [1]: No incoming video signal detected

Is GoPro camera using HDMI port? We have not tried that but the HDMI camera should work. Have you tried to use lower resolution? Have you tried to use laptop source first as a starting point?

Yes, I’ve tried both the camera and a laptop at a resolution of 720p. What could be the cause of this problem ?

Are you sure the output of the laptop is set properly?

The cause is clearly stated in the error: “No incoming video signal detected”

Assuming the board is working correctly, either there is no incoming video signal, or it is in a format that the board can’t understand. Have you tried other resolutions with the laptop? HAve you any other source you can try?

Cathal

The source is perfect. In fact I’ve tried the same with pynq z2 board but i get the exact same error still. I’ve tried setting my laptop to 800x600 resolution and all the way up to 1920x1080. Nothing seems to work.

If you have tried on both boards and you are getting the same error, then it’s probably something you are doing/not doing. I doubt both boards are faulty, and if that’s happening also with your laptop, it’s unlikely an incompatibility issue with the GoPro.

Let’s try and get the laptop to work first since that is a use case we actually tested extensively on multiple boards and we are sure it works. Did you enable the “display” in your laptop settings? In windows e.g. once you connect the board through HDMI, in some cases you need to go to the screen settings and manually enable that “display” or PYNQ won’t be able to detect the source.
Also, silly question, did you make sure you are using the correct HDMI_in port?

As you suggested, I checked display settings in Windows. I did the following:

Control panel > Devices > Digilent-DVI2(this is the board, has a monitor icon) > right click on Digilent- DVI2 > Dsiplay settings > detect.
Then, I ran the notebook again, but I still got the same error: No incoming video signal detected.
This is how the settings looked.

This is interesting.
Indeed from the picture (assuming you have only one monitor and the 2nd “display” is in fact the connected board) it seems the source is active and you are duplicating your main display to the board, so this part seems rightly done.
Though a note: “detect” does not do what I meant. You need to “activate” the display, by setting one of the option under “multiple displays” for that specific display like “Duplicate these displays” or “extend desktop to this display”. However, it seems to me you already did that.

The weird part in my opinion is that you are not able to make it work either the Z1 or the Z2. If both boards are not working, I can hardly think that both boards are faulty. We tested extensively HDMI on both and I can confirm it should be working without hiccups.

Some next steps I would suggest:

  • Make sure you are running the latest, (unmodified, at least for this troubleshooting) PYNQ image (2.5). Try burning the image again onto an sdcard and use this fresh image for your future testing.
  • Try again the same steps with the other board you have
  • Try changing HDMI cable (?)
  • Can you share the notebook you are using? It seems from the name, it is not one of ours, so it would be good to have a look at it as well.

I apologize in advance for not being very insightful here, but it is quite hard to troubleshoot this remotely. Again, we extensively test features before any release, of course things can always go unexpectedly in some cases but the fact that it is not working for both boards is what really suprises me.