PYNQ custom image v2.7 for Zedboard no device found error


I am trying to load an Overlay file inside Jupyter Notebook. However I get this error: UserWarning: No devices found, is the XRT environment sourced? Please help me with where I am going wrong.

Steps I used for building custom PYNQ image for Zedboard:

For making the custom PYNQ image(version 2.7), I used Ubuntu 18.04 Virtualbox with Vivado, Vitis and Petalinux version 2020.2.

This is the Zedboard.spec file:

ARCH_Zedboard := arm
BSP_Zedboard := avnet-digilent-zedboard-v2020.2-final.bsp
STAGE4_PACKAGES_Zedboard := boot_leds ethernet pynq jupyter

I downloaded the BSP from the Xilinx Vivado website. Link

I generated the Zedboard pynq image inside sdbuild folder using
make PREBUILT=./focal.arm.2.7.0_2021_11_17.tar.gz BOARDS=Zedboard PYNQ_SDIST=./pynq-2.7.0.tar.gz

PYNQ_SDIST file was taken from here: link



I tried following this solution of sourcing the appropriate venv but still the problem persists.

Can you check this?

When I run xbutil dump in the terminal, I get bash: xbutil: command not found

Here is the output:

Hi @Bala_Dhinesh,

Is xrt included in your STAGE4_PACKAGES? Something like this PYNQ/Pynq-Z2.spec at master · Xilinx/PYNQ · GitHub

If not, add it and rebuild the image.

It is not included in the image. I will rebuild the image, Thanks!

Have you solved it ? Do you have a .hwh file in the same directory?

Sorry for the late reply. Yes, it works. I need to include xrt in STAGE4_PACKAGES while creating the PYNQ image.

1 Like