PYNQ: PYTHON PRODUCTIVITY

RuntimeError: Root permission needed by the library

Hi all,

I am trying to download the finn examples here. GitHub - Xilinx/finn-examples: Dataflow QNN inference accelerator examples on FPGAs
However, I get stuck at this particular step:
pynq get-notebooks --from-package finn-examples -p .
And got this error message:

Traceback (most recent call last):
  File "/usr/local/bin/pynq-get-notebooks", line 8, in <module>
    sys.exit(main())
  File "/usr/local/lib/python3.6/dist-packages/pynq/_cli/get_notebooks.py", line 154, in main
    device = _detect_devices(active_only=True)
  File "/usr/local/lib/python3.6/dist-packages/pynq/utils.py", line 162, in _detect_devices
    devices = Device.devices
  File "/usr/local/lib/python3.6/dist-packages/pynq/pl_server/device.py", line 79, in devices
    cls._devices.extend(DeviceMeta._subclasses[key]._probe_())
  File "/usr/local/lib/python3.6/dist-packages/pynq/pl_server/device.py", line 677, in _probe_
    return [XlnkDevice()]
  File "/usr/local/lib/python3.6/dist-packages/pynq/pl_server/device.py", line 686, in __init__
    self.default_memory = Xlnk()
  File "/usr/local/lib/python3.6/dist-packages/pynq/xlnk.py", line 137, in __init__
    raise RuntimeError("Root permission needed by the library.")
RuntimeError: Root permission needed by the library.
Exception ignored in: <bound method Xlnk.__del__ of <pynq.xlnk.Xlnk object at 0x7faae99f28>>
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/dist-packages/pynq/xlnk.py", line 154, in __del__
    for key in self.bufmap.keys():
AttributeError: 'Xlnk' object has no attribute 'bufmap'

I have tried adding sudo which I can load the notebook successfully. But it doesnt work when I try to run the jupyter notebook itself (tried adding --allow-root) and it gives me the same error. I am login to the board as xilinx and not allowed to use root.

PYNQ version 2.6.0
Git Id: 56d3c1ba60d24160a946551f0b82711660ac71ca
Board: Ultra96-v2
Architecture: aarch64
Byte Order: Little Endian
CPU(s): 4
On-line CPU(s) list: 0-3
Thread(s) per core: 1
Core(s) per socket: 4
Socket(s): 1
Vendor ID: ARM
Model: 4
Model name: Cortex-A53
Stepping: r0p4
CPU max MHz: 1199.9990
CPU min MHz: 299.9990
BogoMIPS: 199.99
Flags: fp asimd evtstrm aes pmull sha1 sha2 crc32 cpuid

Some libraries like memory map require root permission. So please follow the instructions and use sudo for now. It may be an improvement to allow non-sudo behavior but that is not on our priority list now.

sudo didn’t work
Jupyter notebook itself blocks sudo usage