ZCU208/ZCU216 MMIO does not work

Hi all,

We are still trying to build the ZCU208 pynq image. I guess we’re quite close, but still some functions does not work.

We just build the PYNQ image for the ZCU208 with Ubuntu 20.04, Vivado 20.2 and the associated petalinux and bsp files. Furthermore, we also added the .spec file, the two tics files and all spi drivers as mentioned here: ZCU216-PYNQ .

For our understanding we had to add all these things from the ZCU216 image, because we now have a different clock board (the clk104 board) and different PLL drivers.
But how about all the other pynq functions, e.g. mmio, gpio, etc.?
We have assumed that we can use these functions just as usual, as we did for example with the ZCU111 board? We had all the pynq functions in our image build.

Unfortunately, it does not work for us. If I do a simple test, where I write a single value into address=base_address+4, I can’t read the value I just wrote.


Do you have an idea, what went wrong? Or can’t we just use the general function as mmio, gpio on the boards like ZCU216, ZCU208 as usual?

Thanks for your help!

Best regards

1 Like

I tried to run the mmio functions in Python using the command window using Putty…
When I import the MMIO function, I got this XRT error message.
Maybe this gives a hint?


Hi there,

I think you should be able to use mmio just like on other boards. Have you tried accessing any other memory addresses, like ddr4?

On the xrt issue, did your .spec include the xrt package?