Building PYNQ-Z2 image fails with mkfs.ext4: Ext2 inode


First of all, here is my setup after following the Getting started documentation:

  • systemd-nspawn Ubuntu 20.04. I originally tried with Vagrant, but there were a lot of weird permission bugs or something, so I gave up on it.
  • Installed Vivado 2022.1, Vitis 2022.1, PetaLinux 2022.1
  • Cloned PYNQ repository into my workspace folder
  • Ran <pynq>/sdbuild/scripts/ without error
  • Sourced <PetaLinux>/ and <Vitis>/2022.1/
  • Vivado and Vitis launch without error (I had to install a few things like ncurses6 and en_US locale iirc)

Unrelated to my current issue, but I believe there is a mistake in the board-agnostic images for arm architecture. The downloaded file’s name ends only with .gz instead of .tar.gz. I got somewhat confused by this, but a simple rename seemed to remove the make issues.

Now about my main issue. I am currently trying to use sdbuild to build Pynq 3.0.1 for my Zybo Z7-20 board. I figured I would try to build for an officially supported board first to see if everything was okay, so I ran
$ make BOARDS=Pynq-Z2 in <pynq>/sdbuild. After a while I get the following error message:

I have tried searching for fixes online, but found no mention of this issue.

Thanks for any help or tips