Does pynq-z1 support ubuntu 22.04?


I used pynq and jupyter notebook in ubuntu 20.04.

However, pynq doesn’t work after upgrading from ubuntu 20.04 to 22.04.

All the setup has been finished when I was working with ubuntu 20.04 and pynq worked well.

I have followed pynq z1 setup guide

After “Board Setup” (all LEDs worked well), I checked “Other Locations” in “Files” and it is like below.

When I use ubuntu 20.04, there was a symbol like “xilinx” or “pynq”.

Because there’s no symbol like that, I can’t access jupyter notebook with “192.168.2”

Does it occur because ethernet settings is not complete, or because of matter of board?

all settings are not changed, so it is confusing

I have solved this issue.

I have just followed this link again.

link: Static IP address Configuration Issue

When upgrading to Ubuntu 22.04, my Ethernet interface automatically is set to be disable.

After following this one, all works well as same before.

I leave this post for people who have the same trouble

1 Like