PYNQ: PYTHON PRODUCTIVITY

Failed to install sklearn on PYNQ-Z2 with PYNQ v2.5

Hi Sir,
I have tried to use the above command mentioned to install sklearn on pynq z2 board with 2.5 image and I’m getting this error. Can you kindly help me with this.

I’m working with a PC connected to the board. i have given internet access to cpu and with another internet cable to the board. i want to confirm is it the right way I’m proceeding? and can we install sklearn directly on the terminal?

Of course, you can install it on the terminal. It seems like you don’t have an internet connection to the board. Can you check with ping a website? or you are using putty or similar, try with sudo.

okay sir, ill check. Thank you for the response.

Sir, i have tried to ping google.com. its working. can you kindly suggest what is the solution for the error i’m getting.


Please don’t reply to topics 2 years old with new issues. I’ve edited this to make it a new topic.

This isn’t really a PYNQ issue. Your problem is that you can’t stall this package onto an ARM/Ubuntu based embedded platform.
Did you check the requirements for the package you want?

You can see the error messages. Did you try to search for them? As Zynq is ARM based, you may find solutions on Raspberry Pi or similar forums for ARM embedded systems.

Cathal

Cathal

1 Like

I agree with Cathal. It’s not a pynq related issue. As it seems, the package name should be like below:
pip install -U scikit-learn

1 Like