PYNQ: PYTHON PRODUCTIVITY

PYNQ 2.5.1 custom board building mixed with pynq boards

Hi,
I am building PYNQ for custom board. For Pynq 2.4 everything is ok. But in the middle of Pynq 2.5.1 building process I’ve got message:

  • ‘[’ Unknown ‘!=’ Unknown ‘]’
  • ‘[’ -n ‘’ ‘]’
  • ‘[’ -n ‘’ ‘]’
  • cd /home/user/PYNQ/sdbuild/build/PYNQ
  • ./build.sh
    ./build.sh
    Script for building default overlays, microblaze bsp’s and binaries.
    building bitstream logictools.bit for Pynq-Z1
    make[1]: Entering directory ‘/home/user/PYNQ/sdbuild/build/PYNQ/boards/Pynq-Z1/logictools’

and then Pynq build everything for includded boards Z1, Z2 and ZCU104. It means logictools and other Vivado compilation steps. What is worse ZCU104 requires dedicated Xilinx license. My .spec board file:
ARCH_EPD100 := arm
BSP_EPD100 :=
BITSTREAM_EPD100 := base/base.bit

STAGE4_PACKAGES_EPD100 := pynq ethernet

I am using command: make BOARDS=EPD100
How to disable this procedure?
Stefan

We are aware of this and we fixed it, but it is currently not documented on readthedocs, a forum search would have helped. In any case, we introduced two options that will be helpful to you (in particular, what you are looking for is the PYNQ_SDIST option for make, the PREBUILT will also speed-up tremendously your build in case you are not making changes to the rootfs):

The two options are documented here: https://github.com/Xilinx/PYNQ/tree/master/sdbuild
and here (not yet updated on readthedocs): https://github.com/Xilinx/PYNQ/blob/master/docs/source/pynq_sd_card.rst
In particular:

The relevant excerpt from the sdbuild readme:

To use a board-agnostic image to build a board-specific image you can pass the PREBUILT variable:

make PREBUILT=<image path> BOARDS=<board>

To use a previously built PYNQ source distribution tarball you can pass the PYNQ_SDIST variable. This will also avoid having to rebuild bitstreams (except for external boards) and MicroBlazes’ bsps and binaries.

make PYNQ_SDIST=<sdist tarball path>