Pynq 2.7 built for non-official board cannot load overlays

I built pynq 2.7 for a board called Alinx AXU2CG, all goes well until I meet this:

It says “No device found”, and I cannot load an overlay. I tried to use the C program “fpgautil.c” to download my bitstream and succeeded. It seems that the fpga manager works correctly. Can anyone help me? Thanks a lot!


Did you build the image with XRT? Since 2.7 XRT is needed


Hello, and thank you! I used the script “” to build. I found that I made a mistake in my building process. The bsp is built by petalinux 2020.1, but the prebuilt image and pynq are V2.7, which means I should use petalinux 2020.2. I tried to build with V2.6, finally I succeeded. Maybe because I used old version of bsp, the XRT is missed. Thank you again!

Hi, I’m also using this board but I’m a complete newbie here. Could you share the build flow? Or do you know how to obtain a bsp file for 2022.1 tools? I’m not sure if I could build it or I should consult the manufacturer.

I build one from some .xsa file without a bsp. The build process is successful but on boot the kernel panics.


See this guide for compiling the image: