PYNQ: PYTHON PRODUCTIVITY

Is there a way to build Pynq overlay using 2021.1 BSP file

Somehow for our custom ultra-scale + board, ethernet ports are not working for BSP 2020.1 file. So we would like to use the 2021.1 BSP file, just we want to know is there way?

Make command giving a lot of errors which is hard to fix, so we are using prebuilt image command.

1 Like

Hi,

It would be useful if you provide more information such as the branch you are using, what have you done and what error you are getting.

The latest PYNQ version is 2.7 which is merged into master, this is tied to 2020.2 Xilinx tools. The build flow is only validated with the associated Xilinx tool version for given release.

Mario

1 Like

Thank you for your response. we are using

Pynq brach :v2.60
Vivado version 2020.1
petalinux 2020.1
Ubuntu 18.04.6

When I boot if i check for mii devices

Welcome to minicom 2.7.1

OPTIONS: I18n 
Compiled on Aug 13 2017, 15:25:34.
Port /dev/ttyUSB0, 08:06:34

Press CTRL-A Z for help on special keys

Xilinx Zynq MP First Stage Boot Loader 
Release 2020.1   Dec  3 2021  -  14:39:49
NOTICE:  ATF running on XCZU4EG/EV/silicon v4/RTL5.1 at 0xfffea000
NOTICE:  BL31: v2.2(release):xilinx_rebase_v2.2_2020.1
NOTICE:  BL31: Built : 14:41:11, Dec  3 2021


U-Boot 2020.01 (Dec 03 2021 - 14:38:29 +0000)

Board: Xilinx ZynqMP
DRAM:  2 GiB
usb dr_mode not found
PMUFW:  v1.1
EL Level:       EL2
Chip ID:        zu4                                                             
NAND:  0 MiB                                                                    
MMC:   mmc@ff160000: 0, mmc@ff170000: 1                                         
In:    serial@ff000000                                                          
Out:   serial@ff000000                                                          
Err:   serial@ff000000                                                          
Bootmode: SD_MODE1                                                              
Reset reason:   EXTERNAL                                                        
Net:                                                                            
ZYNQ GEM: ff0b0000, mdio bus ff0b0000, phyaddr -1, interface sgmii              
                                                                                
Warning: ethernet@ff0b0000 (eth0) using random MAC address - aa:cc:af:8e:d6:c3  
eth0: ethernet@ff0b0000                                                         
ZYNQ GEM: ff0d0000, mdio bus ff0d0000, phyaddr -1, interface sgmii              
                                                                                
Warning: ethernet@ff0d0000 (eth1) using random MAC address - fa:49:5d:2d:84:2d  
, eth1: ethernet@ff0d0000                                                       
Hit any key to stop autoboot:  0                                                
ZynqMP> mii devices                                                             
MII devices: 'eth0' 'eth1'                                                      
Current device: 'eth0'                                                          
ZynqMP> 

But i don’t see any lights blinking at Ethernet port, its totally non responsive. (same device tree settings and design works fine in petalinux2021.1 our both Ethernet ports works fine)

After boot

xilinx@pynq:~$ ls                                                               
jupyter_notebooks  pynq  REVISION                                               
xilinx@pynq:~$ 
xilinx@pynq:~$ ifconfig                                                         
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536                                    
        inet 127.0.0.1  netmask 255.0.0.0                                       
        inet6 ::1  prefixlen 128  scopeid 0x10<host>                            
        loop  txqueuelen 1000  (Local Loopback)                                 
        RX packets 150  bytes 7456 (7.4 KB)                                     
        RX errors 0  dropped 0  overruns 0  frame 0                             
        TX packets 150  bytes 7456 (7.4 KB)                                     
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0              
                                                                                
xilinx@pynq:~$ sudo ifconfig eth0 192.168.2.99 up                               
[sudo] password for xilinx:                                                     
xilinx@pynq:~$ ifconfig                                                         
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500                      
        inet 192.168.2.99  netmask 255.255.255.0  broadcast 192.168.2.255       
        inet6 fe80::a8cc:afff:fe8e:d6c3  prefixlen 64  scopeid 0x20<link>       
        ether aa:cc:af:8e:d6:c3  txqueuelen 1000  (Ethernet)                    
        RX packets 0  bytes 0 (0.0 B)                                           
        RX errors 0  dropped 0  overruns 0  frame 0                             
        TX packets 6  bytes 540 (540.0 B)                                       
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0              
        device interrupt 31                                                     
                                                                                
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536                                    
        inet 127.0.0.1  netmask 255.0.0.0                                       
        inet6 ::1  prefixlen 128  scopeid 0x10<host>                            
        loop  txqueuelen 1000  (Local Loopback)                                 
        RX packets 150  bytes 7456 (7.4 KB)                                     
        RX errors 0  dropped 0  overruns 0  frame 0                             
        TX packets 150  bytes 7456 (7.4 KB)                                     
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0              
                                                                                
xilinx@pynq:~$ 


And jupyter notebook failed to launch

xilinx@pynq:~$ systemctl status jupyter                                         
��● jupyter.service - Jupyter Notebook Server                                   
   Loaded: loaded (/lib/systemd/system/jupyter.service; enabled; vendor preset: 
   Active: failed (Result: timeout) since Mon 2020-10-19 14:57:46 UTC; 2min 32s 
  Process: 345 ExecStart=/usr/local/bin/start_jupyter.sh (code=killed, signal=TE
                                                                                
Oct 19 14:57:40 pynq start_jupyter.sh[345]: Waiting for Jupyter                 
Oct 19 14:57:41 pynq start_jupyter.sh[345]: Waiting for Jupyter                 
Oct 19 14:57:42 pynq start_jupyter.sh[345]: Waiting for Jupyter                 
Oct 19 14:57:43 pynq start_jupyter.sh[345]: Waiting for Jupyter                 
Oct 19 14:57:44 pynq start_jupyter.sh[345]: Waiting for Jupyter                 
Oct 19 14:57:45 pynq start_jupyter.sh[345]: Waiting for Jupyter                 
Oct 19 14:57:46 pynq start_jupyter.sh[345]: Waiting for Jupyter                 
Oct 19 14:57:46 pynq systemd[1]: jupyter.service: Start operation timed out. Ter
Oct 19 14:57:46 pynq systemd[1]: jupyter.service: Failed with result 'timeout'. 
Oct 19 14:57:46 pynq systemd[1]: Failed to start Jupyter Notebook Server.       
lines 1-15/15 (END)