PYNQ 3.0.1 can not loading Overlay: No Device Found

Hello, I’m using PYNQ 3.0.1 on my own board, the board is 7Z035 from ALinx, I have already built the iamge and boot Ubuntu successfully, but I can not load Overlay in jupyter notebook or in the terminal, get eroor: No Device Found
errorlog.txt (1.9 KB)
)
I have tried:
1.check /dev/xlnk, shows:

xilinx@pynq:/dev$ ls
block mapper ram2 tty16 tty37 tty58 vcsa2
btrfs-control mem ram3 tty17 tty38 tty59 vcsa3
char mmcblk0 ram4 tty18 tty39 tty6 vcsa4
console mmcblk0p1 ram5 tty19 tty4 tty60 vcsa5
cpu_dma_latency mmcblk0p2 ram6 tty2 tty40 tty61 vcsa6
disk mmcblk1 ram7 tty20 tty41 tty62 vcsu
fd mmcblk1boot0 ram8 tty21 tty42 tty63 vcsu1
fpga0 mmcblk1boot1 ram9 tty22 tty43 tty7 vcsu2
full mmcblk1rpmb random tty23 tty44 tty8 vcsu3
gpiochip0 mqueue shm tty24 tty45 tty9 vcsu4
iio:device0 net snd tty25 tty46 ttyPS0 vcsu5
initctl null stderr tty26 tty47 udmabuf vcsu6
kmsg port stdin tty27 tty48 uio0 vga_arbiter
log ptmx stdout tty28 tty49 urandom watchdog
loop0 pts tty tty29 tty5 vcs watchdog0
loop1 ram0 tty0 tty3 tty50 vcs1 xlnk
loop2 ram1 tty1 tty30 tty51 vcs2 zero
loop3 ram10 tty10 tty31 tty52 vcs3
loop4 ram11 tty11 tty32 tty53 vcs4
loop5 ram12 tty12 tty33 tty54 vcs5
loop6 ram13 tty13 tty34 tty55 vcs6
loop7 ram14 tty14 tty35 tty56 vcsa
loop-control ram15 tty15 tty36 tty57 vcsa1s

  1. source /etc/profile.d/pynq_env.sh with sudo -i and run python ->not work
  2. export XILINX_XRT=/usr ->not work (also tried with sudo)
  3. sudo xbutil examine ,get:

System Configuration
OS Name : Linux
Release : 5.15.19-xilinx-v2022.1
Version : #1 SMP PREEMPT Mon Apr 11 17:52:14 UTC 2022
Machine : armv7l
CPU Cores : 2
Memory : 1000 MB
Distribution : PynqLinux, based on Ubuntu 22.04
GLIBC : 2.35
Model : unknown

XRT
Version : 2.13.0
Branch : temp
Hash : f5505e402c2ca1ffe45eb6d3a9399b23a0dc8776
Hash Date : 2022-10-21 17:40:17
ZOCL : 2.13.0, f5505e402c2ca1ffe45eb6d3a9399b23a0dc8776

Devices present
0 devices found
BDF : Shell Platform UUID Device ID Device Ready*

  • Devices that are not ready will have reduced functionality when using XRT tools

Here is my spec file when build:

ARCH_Alinx7035 := arm
BSP_Alinx7035 := Alinx7035.bsp
BITSTREAM_Alinx7035 := base/7035_base.bit
FPGA_MANAGER_Alinx7035 := 1

STAGE4_PACKAGES_ALinx7035 := xrt pynq ethernet precached_metadata pynq_peripherals sdcardshrink

can anyone help me with this or give me some advice? Thanks a lot~

1 Like

I’ve solved this! thanks!

1 Like

Hi @Xyin, it would be good if you can provide the solution, as other may find it useful as well.

Mario

1 Like