PYNQ: PYTHON PRODUCTIVITY

Pynq Build Error -- libxcb

Hi I got PYNQ build failing several times.
Specifically near 99% when downloading Ubuntu packages.

Using Petalinux 2019.1 and Ubuntu 2018
Tried it with Ubuntu 2018, same error
I used “vagrant up” to create the VM

LOGS: (removing http – because can’t post more than 2 links)

Get:1509 ubuntu-ports bionic/main armhf ssh-import-id all 5.7-0ubuntu1 [10.4 kB]
Get:1510 ubuntu-ports bionic/main armhf usb-modeswitch-data all 20170806-2 [30.7 kB]
Get:1511 ubuntu-ports bionic/main armhf usb-modeswitch armhf 2.5.2+repack0-2ubuntu1 [50.7 kB]
Get:1512 ubuntu-ports bionic/main armhf xserver-xorg-legacy armhf 2:1.19.6-1ubuntu4 [32.4 kB]
Fetched 673 MB in 56min 7s (200 kB/s)
E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/pool/main/libx/libxcb/libxcb-randr0_1.13-1_armhf.deb Hash Sum mismatch

E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/pool/universe/i/isl-0.18/libisl15_0.18-4_armhf.deb Hash Sum mismatch

E: Some files failed to download
apt download failed. Exit value: 100
Makefile:322: recipe for target ‘/workspace/builds/PYNQ/sdbuild/build/bionic.arm.stage1.img’ failed
make: *** [/workspace/builds/PYNQ/sdbuild/build/bionic.arm.stage1.img] Error 100

Also, is it possible to restart the build form the same point.
I have to run the build process again every-time after this error

Are you behind a proxy or just using home network?

I am not using Home network, working behind university routers. There is a possibility that there is some proxy issues with routers.

Add proxy variable (adjust gateway in the following) to your build machine.

export HTTP_PROXY=http://gateway:8080
export HTTPS_PROXY=http://gateway:8080
export http_proxy=http://gateway:8080
export https_proxy=http://gateway:8080
export ftp_proxy=http://gateway:8080