PYNQ: PYTHON PRODUCTIVITY FOR ZYNQ

RALink WiFi dongle with PYNQ/pynq/notebooks/common/wifi.ipynb

Hi, dear elites,

For PYNQ-Z1 connecting to USB WiFi Dongle, I found the following example. However, does anyone know if it’s a MUST to only use RALink WiFi dongle. Since I browsed many articles, the common point is that all porting of USB WiFi Dongle on PYNQ uses RALink WiFi dongle.

Are there others enabling other types of USB WiFi Dongles on PYNQ successfully?

Also, what’s the difference to directly install the USB WiFi Dongle drivers on Ubuntu 18.04 against the usage of image_v2.4/pynq/notebooks/common/wifi.ipynb ??

Thank you

I have used the TP-Link TL-WN823N dongle successfully with the Pynq-Z2.

Hi, Rob,

Thank you for your sharing and comment. May I ask you one more question ?

Do you just install the driver of TP-Link TL-WN823N on the Ubuntu 18.04 or use the test code in the following link provided by Xilinx?

I just plugged it in and used the /notebooks/common/wifi.ipynb to connect to my local network.

Hi, Rob,

Thanks for the comment.

Don’t you edit the following file first and then execute “sudo ifdown wlan0” and then “sudo ifup -v wlan0” ? You only plugged in the USB Wifi dongle and then execute the /notebooks/common/wifi.ipynb. Is it that case ?

/etc/network/interfaces

add these part

auto wlan0
iface wlan0 inet dhcp
wpa-ssid xxxxxx
wpa-psk yyyyyy

No. I did not edit any file.

xilinx@pynq:~$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d
xilinx@pynq:~$ ls /etc/network/interfaces.d
eth0  wlan0

That file, wlan0, is written by the wifi notebook. Run the three Python cells in the notebook. It will ask you for SSID and password, then write the wlan0 file, bring up the interface, then test the network connection via that interface.

1 Like

Hi, Rob,

Thank you for the comment again.

I have the last question. Don’t you install any driver and only plug-n-play and then it works on v2.4 PYNQ-Z2 board out of the box ?

All the best,
NS

You should not need to do any extra thing - just plug in and run that notebook - it does all the steps.

Thank you.
Finally, I purchased RT5370-based USB wifi adapter and it works as you mentioned.