PYNQ: PYTHON PRODUCTIVITY FOR ZYNQ

Recipe for target 'checkenv' failed

I have installed SDx, petalinux , SDK and Vivado 2018.3 in the downloads/downloads1 folder in my home directory.
then i source the files using the source command
then i have git cloned the pynq repo
I have created a folder myboards/ZedBoard in it
inside the ZedBoard folder i have put the spec file
with BSP as the one i downloaded from the petalinux website of xilinx for zedboard.
i have left the bitportion empty.

then i run make BOARDDIR =home/adsc/PYNQ/myboards

this error comes–
which petalinux-config | fgrep 2018.3
Makefile:309: recipe for target ‘checkenv’ failed
make: *** [checkenv] Error 1

But if i type which petalinux-config on the teminal it is pointing to the following path adsc@adsc-i5-fpga:~$ which petalinux-config
/home/adsc/Downloads/Downloads1/petalinux/tools/common/petalinux/bin/petalinux-config

What can be the issue?

There is an incorrect assumption that’s been made in the Makefile that Petalinux is installed in a directory that includes the version name as that is how we generally set up our machines to handle multiple versions - similar to the way Vivado is installed. I’d get rid of the fgrep in line 309 of the Makefile so that it is just which petalinux-config. and we’ll try to determine another way making sure that the version is correct for the next release.

Peter

1 Like

Thanks a lot. I changed it. i see when the process is continuing it has created two partitions by itself in the hard disk of sizes 7.4 GB and 105 MB and storing the files there.
The 7.4 GB partition is storing folders under pynq/build/bionic.arm
I did not create sd card partitions now and didnt insert the card before running the makefile.
Should i wait for the process to complete or i stop it, insert my sd card and rerun make BOARDDIR command? I was thinking it will make the image file in the pynq directory that i git cloned.

There is no need to insert the sd card until the build is complete. I, for example, use a cloud VM for building and at the end copy the image file on my local win7 laptop and write the image on the SD card with Win32DiskImager

1 Like

Thanks a lot for your reply. I will keep updating you guys. It is indeed a learning experience.

It ran for about an hour and this error came.
home/adsc/Downloads/Downloads1/PYNQ/sdbuild/scripts/unmount_image.sh /home/adsc/Downloads/Downloads1/PYNQ/sdbuild/build/bionic.arm /home/adsc/Downloads/Downloads1/PYNQ/sdbuild/build/bionic.arm.stage1.img*

  • set -e
  • target=/home/adsc/Downloads/Downloads1/PYNQ/sdbuild/build/bionic.arm
  • image_file=/home/adsc/Downloads/Downloads1/PYNQ/sdbuild/build/bionic.arm.stage1.img
  • sudo umount /home/adsc/Downloads/Downloads1/PYNQ/sdbuild/build/bionic.arm/boot
    umount: /home/adsc/Downloads/Downloads1/PYNQ/sdbuild/build/bionic.arm/boot: not mounted
    Makefile:299: recipe for target ‘/home/adsc/Downloads/Downloads1/PYNQ/sdbuild/build/bionic.arm.stage1.img’ failed

    make: *** [/home/adsc/Downloads/Downloads1/PYNQ/sdbuild/build/bionic.arm.stage1.img] Error 32

I think my partition of 105 MB is showing blank. Maybe thats the issue. The other partition of 7.2 GB is showing files.

In the sdbuild/build the bionic.armstage1.img is present.
What can be the issue?

I’ve not seen that failure before. I don’t suppose you have more of the console output you could provide? Attaching it as a file is probably best due to the amount of text that can get printed.

The boot partition (100MB one) does not get populated until the very end of the process but should get mounted at the start. I’m very intrigued as to why it hasn’t.

Peter

1 Like

I had similar problems with the VM I build on running out of disk space…
In particular while the disk was 200GB,but my /home/…/PYNQ was on a 20GB partition and that got quickly filled up with partial images and the build failed, so I had /PYNQ moved to a 100GB partition subfolder and I finally got it done. Check your build VM disk partitioning

1 Like

It was asking for password to mount the boot partition( the bionic arm partition however didnt ask for password) . I was out when the process was running. I think because the key wasnt provided it didnt get mounted.
Can this be the reason?
Is this the reason a passwordless sudo was assumed at the start?
Tomorrow i will go back and try again and send the full error text if it comes.
I had a doubt .Since some of the processes have been executed , should i run a make clean before rerunning it?
Or i can just run the make BOARDDIR =Absolute_path to pynq/myboards again?

You need a passwordless sudo. Yes.

To pick up from what has been left in the system you can run make BOARDDIR=… but it is probably safer to start after a make clean.