Tar: cannot hard link to 'crosstool-ng-1.24.0.tar.bz2'

Hi dear friends, I installed UBUNTU v 2018 with vagrant file , when I run setup_host.sh, process is encounterd with error. How can I fix this problem

1 Like


Set up passwordless permission on your ubuntu for the period of this installation

I ran into same situation. How to setup passwordless permission.


Before running setup script, change PYNQ GIT repository to all right

chmod 777 -R ./PYNQ/*
There is a setup script in the PYNQ, use that to setup environment.

Step 13 should help you out quick =]



1 Like

Didn’t work for me.
After using this script:

chmod 777 -R ./PYNQ/*

I get this errors:

chmod: changing permissions of './pynq/lib/_pynq/_video/bsp/gpio': No such file or directory
chmod: changing permissions of './pynq/lib/_pynq/_video/bsp/vtc': No such file or directory

and this error still remains:

Tar: cannot hard link to ‘crosstool-ng-1.24.0.tar.bz2’


BTW did you use “sudo” when changing the right?

I will suggest check alignment between the Vivado and the Ubuntu and the toolchain version. Too little info

My problem was solved by changing PYNQ directory.
I was using virtual machine to run Ubuntu.
PYNQ folder was inside /mnt which was sharing with Window.
By changing PYNQ directory to /home, problem was solved.


I guess you did not read the previous reference:

The setup guide is very clear and mentioned @ 3A step

  1. I will suggest download 18.04.06 LTS Ubuntu from official website
  2. Create a virtual disk size about 200GB or more, set the CPU >#4, RAM >#8192
  3. Update Ubuntu packages before setting up the PYNQ
    3b) Git clone the PYNQ to /home//PYNQ <------
    3c) sudo chmod -R 777 ./PYNQ/*

So i guess the issue had resolved.