PYNQ: PYTHON PRODUCTIVITY FOR ZYNQ

Unable to access 192.168.2.99

I have changed the static IP of my Windows laptop to 192.168.2.98 and the subnet as 255.255.255.0.

For some reason I am unable to connect to the board. I used to be able to but now I am not sure why it isn’t working anymore.

So, I enabled Wi-Fi sharing on my laptop and the board’s dynamic IP(?) changed to 192.168.137.84 and things worked. However, the next day I had problems with my Wi-Fi sharing so I redid the Wi-Fi sharing settings and the board’s dynamic IP changed again to 192.168.137.231. (I found these addresses by running the command prompt and used arp -a to see what is connected to my laptop’s ethernet port)

Things worked well but after switching the board off and on, Jupyter Notebooks started to lag and hang.

So, on a different Windows laptop, I assigned its ethernet port to 192.168.2.98, did not enable Wi-Fi sharing and still cannot connect to the board (192.168.2.99).

I decided to use PuTTY and ran a few commands which made me even more confused as to what is going on.

Sorry for this long story. Hope I did not do something wrong.

You can connect a terminal to the board via USB UART to check the network interface on the board.

Run the following, and check if eth0, and eth0:0 exist and if they have an IP address:

 ifconfig

If you don’t see both eth0, eth0:0, can you try reboot?

Can you report back the output of this, and the IP address of the Ethernet on your laptop?

Cathal

Even after rebooting by running “sudo shutdown -r now”, I am still unable to connect to 192.168.2.99

Ethernet on Laptop IP: 192.168.2.98, 255.255.255.0.

output.txt (30.5 KB)

Just to let you know, this isn’t really PYNQ specific, so you should be able to search Ubuntu forums for networking help.
From the output.txt it seems you have lost the eth0:0 alias for the static IP address.

Can you check this file:
/etc/network/interfaces.d/eth0

It may have been modified. It should look like this by default:

xilinx@pynq:~$ more /etc/network/interfaces.d/eth0
auto eth0
iface eth0 inet dhcp

auto eth0:1
iface eth0:1 inet static
address 192.168.2.99
netmask 255.255.255.0

You should also be able to configure with this as root:

ifconfig eth0:0 192.168.2.99 up

Cathal