PYNQ: PYTHON PRODUCTIVITY

Confing file not detected by make file ? Making image Zedboard-7000 PYNQ 2.6,

Hello, I am trying to make an image for Zedboard-7000, tried many things and i am ultimately stuck with the following errors.

a file failes to get created and i first get the following error :

the problem is i know the file exists i can even nano into it:

/pynq/sdbuild/build/ZedBoard/petalinux_project/project-spec/configs/config

i would really love some Help with this please !

Here is the said config file :

Here is the command am using :

make PREBUILT=/pynq/bionic.arm.2.6.0_2020_10_19.img BOARDDIR=/pynq/myboards

This is my Spec ZedBoard.spec file

ARCH_ZedBoard :=arm
BSP_ZedBoard :=avnet-digilent-zedboard-v2020.1-final.bsp
BITSTREAM_ZedBoard :=project_1.bit
STAGE4_PACKAGES_ZedBoard :=pynq

I’ve not seen that particular failure before - can you try running the echo command directly on the shell and then with bash -c?

Peter

Hello Peter thanks for answering, here is the output of the command after retrying to build:
i don’t know if it’s expected not to give anything like this.

So i tried running the echo command alone on the shell (after the make already failed), it does add the correct directory.
when i add bash -c before the echo it doesn’t do anything (doesn’t add anything to the config file) but doesn’t output “no directory”.
the only moment the echo gives no directory is when i run the echo without making the file.

I’m at a loss as to what could be going on. Can you edit the Makefile to do an ls of the file before the echo lines?

Peter

When i ls the parent directory it finds the configs folder :


However when i try to ls inside the config folder it gives operation not permitted.

:confused:

it also seems to have the necessary permissions on the configs directory…

Sounds like the BSP has been packaged with weird permissions on the configs folder. Try adding a chmod a+rx of the configs directory where the ls currently is.

Do you have a link where the BSP came from?

Peter

Yes the BSP came from Xilinx’s website, here :

Zynq-7000 SoC Board Support Packages - 2020.1, ZED BSP

actual link where you can see

i’ll try to edit the permissions right now :
tried to edit the permissions and it still doesn’t work, for some reason it considers there is no such file or directory, even though we can see it is here on the ls.

I would gladly take another BSP if you have a better link,
would a 2020.2 work ?
would an earlier version work ?

and Thanks for all the support you are amazing, i hope i can learn enough to be able to help with all of this.

Trying with BSP 2020.2 and 2019.2 doesn’t fix this issue and comes with the exact same problems.

I’ve been trying to recreate the error on my end and I can’t - the Zedboard BSP creates an image just fine. I’ll have a think on anything else that might be causing the issue

Peter

Hey, I was able to fix this and build images, the problem was that i was trying to run the make file in the /pynq shared folder with my machine, i think vagrant generated VM doesn’t have enough rights to write on that directory.

i had to reclone the PYNQ project on the home of the VM and run the setup_host.sh script.

I would also like some help with making a custom overlay to make the boot_leds blink on startup, not sure if i should open a new thread.