Connecting to the internet - Zynq 104

Hi, first of all, I would like to apologize if my question is redundant my another topic in this forum. But I already tried to find it (the solution) without success.

The problem:-
I am trying to connect the board to the internet to download & install pytorch, etc for my research. The problem is my board can’t connect to the internet. although I can access the board directly from desktop via i) ethernet cable (using static IP) or ii) put it on the same sub-network

I already tried to connect directly the board via router, switch, wifi extender (connect to my main router wirelessly) and using internet sharing from main computer.

But still, can’t connecto to the internet.

Can someone guide me A-Z the steps how to set the board properly, so it can access the internet. Really appreciate your help. Thanks in advanced.


1 Like

If you have the board connected to your network, and you can communicate from your PC, then it should have the same internet access as your PC unless something is blocking it.
If this is a home network there shouldn’t be any problems, but you can check your router settings.
If this is a university or work network, check if there are any proxy settings, and check with your IT department.

How are you testing the connection? If you are only trying to install pytorch, make sure you can ping other wesites on the internet first, then check the links or install method for pytorch.

I don’t know if this will work for PyTorch, but generally you can try download a copy of the github, copy the files to your board and pip install locally from the board.


Thanks for the information.

It is already worked, and I am able to connect to the internet and update my board. So, I am just setting fix IP address both on my board and PC (using same sub network of my switch).

Then, I need to run the following command, which I am not really sure why.

echo "nameserver" | sudo tee /etc/resolv.conf > /dev/null

Each time, I logout out from board, I need to run that command to connect to to internet.

But, at least my problem solved. Many thanks

1 Like

@raihaan you can follow these steps to set permanent DNS nameserver

DNS (Domain Name System) aims at translating url, e.g, to IP addresses. In order to do that a DNS server is contacted to do the translation. is a dns server from google, but there are many others.


Here are my experience with log in to the zcu104 with ethernet:

  1. Plugin your zcu104 board with ethernet
  2. check the IP address from the router administrative page.
  3. login to zcu104 by visiting that IP in your browser.

I tried the solutions suggested above but it doesn’t resolve hostnames. I can ping addresses directly. Due to this I cannot use apt update or upgrade.

I’m using image version 2.6 for ZCU104 and have attached an screenshot of two devices on the same network. I’m using a Windows 10 pc to share internet to this network.

I have attached a screenshot of Pynq Z2 on the left and ZCU104 on the right

Another screenshot with Pynq Z2 on left and ZCU104 on right. I didnt have to do set permanent DNS nameserver for Pynq Z2