Connectivity Issues with PYNQ Z2 Python Server


I’m using a PYNQ Z2 board with v3.0.1 SD card image. I’ve followed all the setup guide steps. But the Jupyter notebook is not working properly. Most of the times, I’m not able to open the server. Sometimes it starts but gets disconnected after few minutes. And very few times, it works works properly.
I’ve tried installing the previous image versions also but they didn’t work at all. I’m able to ping the board with zero data loss. But the issue is with Jupyter notebook. It shows that the PYNQ has refused to connect. I’ve tried it with different PCs and different networks but facing the same issue again and again.
Thanks in advance:)

Hi @Akash,

Welcome to the PYNQ community.

I would be helpful if you can share how your PYNQ-Z2 is connected to the network.
Is this a point to point connection with your computer? Over the network?

In any case, any firewall enabled in your computer or network?


1 Like

Hi @marioruiz,

Thanks for the reply. Actually, I tried both types of connections, and I was facing the same issue.
Now, my problem has been solved by changing the SD card to a new one.


1 Like