PYNQ: PYTHON PRODUCTIVITY FOR ZYNQ

Cannot connect to (custom) board

I managed to build the pynq sd card for a custom board. I connected the board to my home router with the ethernet cable and to a laptop with the USB. I could see the boot log, everything apparently fine. From the laptop I could ping the board at 192.168.1.8 (found with ifconfig, I expected another fixed value !?). But… a browser (chrome) to that IP (or pynq:9090) only shows a blank page and an error message… what can be wrong?

Which version of PYNQ? Did you try :9090 ?

Did you check if the Jupyter server is running on the board?

After that, can you check if there is a setting in your router to restrict traffic from fixed to wireless networks?

It is also possible that your router blocks traffic on port 9090. Can you check for any settings like this?

Are you able to connect the board directly to your laptop with Ethernet? This would help check if the board is OK, and if the issue is with the network setup.

Cathal

yes, I tried specifying the port (only with pynq:9090, not with the ip)
When the board boots I noticed some messages about network service starting or the like… I don’t remember any mention to jupyter notebook though. Could it be I missed something in my build? In case is not running, is it something I can run manually?
I will try tweaking the router and connecting the board to the PC

Depending on the version of PYNQ, you may need to add the port number to the IP. Earlier versions needed the port number.

Jupyter server may not have been included in the build (unlikely I think), it may not have started (unlikely), or may have crashed (possible!).

If you don’t notice anything in the boot log, I think you could try run something like this to check if the process is running
ps -ef | grep jupyter

If it isn’t running check if it is installed:
which jupyter-notebook

To try start it:
jupyter-notebook

If Jupyter is running, I would check for a network problem next.

Cathal

1 Like

I’m using release v2.4

There are two processes containing ‘jupyter’ and running at boot:
xilinx@pynq:~$ ps -ef | grep jupyter
root 1477 1 0 20:25 ? 00:00:00 /bin/bash /usr/local/bin/start_jupyter.sh
root 1593 1477 44 20:25 ? 00:00:13 /usr/bin/python3 /usr/bin/jupyter-notebook --no-browser --allow-root

jupyter-notebook exists:
xilinx@pynq:~$ which jupyter-notebook
/usr/bin/jupyter-notebook

And running it looks promising but the link provided doesn’t connect:
xilinx@pynq:~$ jupyter-notebook
[I 20:28:44.115 NotebookApp] Writing notebook server cookie secret to /run/user/1000/jupyter/notebook_cookie_secret
[I 20:28:46.411 NotebookApp] Serving notebooks from local directory: /home/xilinx
[I 20:28:46.412 NotebookApp] 0 active kernels
[I 20:28:46.413 NotebookApp] The Jupyter Notebook is running at:
[I 20:28:46.413 NotebookApp] http://localhost:8888/?token=476613b739794c581f7b48273fa1dbfc5e89c8d292fb5194
[I 20:28:46.414 NotebookApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation).
[W 20:28:46.417 NotebookApp] No web browser found: could not locate runnable browser.
[C 20:28:46.419 NotebookApp]

Copy/paste this URL into your browser when you connect for the first time,
to login with a token:
http://localhost:8888/?token=476613b739794c581f7b48273fa1dbfc5e89c8d292fb5194

OK, when you see the process running (after ps -ef) this is fine. Jupyter is started. You didn’t need to run it again.

Your problem is with the network connection to the board. Can you check this? Are you able to try connecting the board directly to your laptop?

1 Like

Direct connection didn’t work. Yes, probably some firewall settings, next battle…