Pynq Z2 itermittent connection

I have been using a pynq z2 for the last few weeks. Recently I can no longer have a stable connection to my jupyter notebook. A simple "print(“Hello, world”) takes up to 15 seconds sometimes. Even while pinging the board I get dropped packages consistently. I have tried different cables and computer, always with the same issue. I did have peripherals connected to it. I am wondering if I have damaged it. I have also tried a a new sd card and image but still the problem persists. Any Ideas?

1 Like

This is difficult to debug. I’ve sometimes seen this with a corrupt SD card or one that is failing, but you said you already tried this. Did you use a new SD card when you created a new PYNQ image?


I think you might have nailed it… The connection is now solid. I will discard that micro sd card. I dont know if it is still acting slow, it seems much more responsive. It would be nice to have some sort of benchmark notebook but that is another question. The question of the intermittent connection seems resolved.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.