PYNQ: PYTHON PRODUCTIVITY

DPU-PYNQ v1.4.0 release

Dear PYNQ users,

DPU-PYNQ now officially supports Vitis AI 1.4.0:

This release is compatible with:

  • Vitis AI 1.4.0
  • Vitis / Vivado 2021.1
  • PYNQ v2.7.0 image
  • ZCU104, Ultra96 and KV260

Some notes:

  1. Host scripts have been updated to support PyTorch and Tensorflow2.
  2. The example host notebook has also been upgraded to Tensorflow2, showing the entire flow from host to edge in as few lines as possible.
  3. Please be aware that since PYNQ migrated to a virtual environment you should now install the package with a --no-build-isolation flag.

Please use the PYNQ discussion forum to report any issue.

Thanks,

PYNQ team

4 Likes