PYNQ: PYTHON PRODUCTIVITY

Errors during a DPU software installation on PYNQ

Hi!

I have some problems in the installation of DPU-PYNQ and pynq-dpu.
When I run sudo make from DPU-PYNQ/scripts then I get:

xilinx@pynq:~/jupyter_notebooks/DPU-PYNQ/upgrade$ sudo make
bash ./check_env.sh
upgrading xrt …
++ pwd

  • CURDIR=/home/xilinx/jupyter_notebooks/DPU-PYNQ/upgrade/xrt
  • git clone https://github.com/Xilinx/XRT.git xrt-git
    Cloning into ‘xrt-git’…
    remote: Enumerating objects: 267, done.
    remote: Counting objects: 100% (267/267), done.
    remote: Compressing objects: 100% (215/215), done.
    remote: Total 53511 (delta 81), reused 155 (delta 48), pack-reused 53244
    Receiving objects: 100% (53511/53511), 65.23 MiB | 3.20 MiB/s, done.
    Resolving deltas: 100% (41854/41854), done.
    Checking out files: 100% (1820/1820), done.
  • cd xrt-git
  • git checkout -b temp tags/2019.2_RC2
    Checking out files: 100% (1690/1690), done.
    Switched to a new branch ‘temp’
  • cp -rf …/0001-fix-for-pynq.patch .
  • git apply 0001-fix-for-pynq.patch
  • cd /
  • sudo tar xvzf kernel.tgz
    tar (child): kernel.tgz: Cannot open: No such file or directory
    tar (child): Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error is not recoverable: exiting now
    Makefile:15: recipe for target ‘xrt’ failed
    make: *** [xrt] Error 2

How should I get a kernel.tgz file?

When I skipped the step and I have tried to install pynq-dpu I have got another error:

xilinx@pynq:~/jupyter_notebooks/DPU-PYNQ/upgrade$ pip3 install pynq-dpu
Collecting pynq-dpu
Using cached https://files.pythonhosted.org/packages/28/2a/f8093f377345d9ceca5b89274e19981c46a4ea7a30ea482dfe131edb35f1/pynq_dpu-1.1.2.tar.gz
Complete output from command python setup.py egg_info:
Exception ignored in: <bound method Xlnk.del of <pynq.xlnk.Xlnk object at 0x7fa1116860>>
Traceback (most recent call last):
File “/usr/local/lib/python3.6/dist-packages/pynq/xlnk.py”, line 150, in del
for key in self.bufmap.keys():
AttributeError: ‘Xlnk’ object has no attribute ‘bufmap’
Traceback (most recent call last):
File “”, line 1, in
File “/tmp/pip-build-yk_xwyqq/pynq-dpu/setup.py”, line 256, in
cmdclass={“build_py”: build_py,
NameError: name ‘build_py’ is not defined

----------------------------------------

Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-build-yk_xwyqq/pynq-dpu/

I installed build_py package, but it did not solve the problem. How should I fill all requirements?
I have a custom board based on ZynqMP and generic PYNQ v2.5 image for aarch64 architecture.

Thanks for any reply
Paweł

If it is image v2.5, you should have that file in your rootfs. However, that file is not necessary since it is tarring a symbolic link. Check if you have the path /usr/src/kernel on your rootfs; if so, you are good to remove:

And proceed with the upgrade process.

Hi @rock!
I have the generic image bionic.aarch64.2.5.img. It does not contain any kernel.tgz file. The /user/src/kernel is also not available in the image. This is the reason why the script fails.

I checked a pre-built image for ZCU104 and there the files are present. With the filesystem the script works correctly.

Paweł