PYNQ: PYTHON PRODUCTIVITY

Ultra96v2 ,dpu-pynq install can not run

I want to make my ultra96v2 board support dpu-pynq, and I update my v2.5 image follow the " Quick Start" on github, and it was successful. But when I run “pip3 install pynq-dpu”, the process is stuck in this place for more than 1 hour.
image
So I download the source code folder “pynq_dpu-1.1.2”, and run “ python3 setup.py build” in the folder, and the process is stuck in this place for more than 1 hour.


I want to know if it is normal? What should I do?

I only change the device tree, add the following node that in ug1186(openamp), and rebuild the pynq image using the u96v2-bsp-2019.1. There is no problem when I use it.

reserved-memory {
#address-cells = <2>;
#size-cells = <2>;
ranges;
rproc_0_dma: rproc@3ed40000 {
no-map;
compatible = “shared-dma-pool”;
reg = <0x0 0x3ed40000 0x0 0x100000>;
};
rproc_0_reserved: rproc@3ed00000 {
no-map;
reg = <0x0 0x3ed00000 0x0 0x40000>;
};
};

zynqmp-rpu {
compatible = “xlnx,zynqmp-r5-remoteproc-1.0”;
#address-cells = <2>;
#size-cells = <2>;
ranges;
core_conf = “split”;
r5_0: r5@0 {
#address-cells = <2>;
#size-cells = <2>;
ranges;
memory-region = <&rproc_0_reserved>, <&rproc_0_dma>;
pnode-id = <0x7>;
mboxes = <&ipi_mailbox_rpu0 0>, <&ipi_mailbox_rpu0 1>;
mbox-names = “tx”, “rx”;
tcm_0_a: tcm_0@0 {
reg = <0x0 0xFFE00000 0x0 0x10000>;
pnode-id = <0xf>;
};
tcm_0_b: tcm_0@1 {
reg = <0x0 0xFFE20000 0x0 0x10000>;
pnode-id = <0x10>;
};
};
};

zynqmp_ipi1 {
compatible = “xlnx,zynqmp-ipi-mailbox”;
interrupt-parent = <&gic>;
interrupts = <0 29 4>;
xlnx,ipi-id = <7>;
#address-cells = <1>;
#size-cells = <1>;
ranges;
/* APU<->RPU0 IPI mailbox controller */
ipi_mailbox_rpu0: mailbox@ff90000 {
reg = <0xff990600 0x20>,
<0xff990620 0x20>,
<0xff9900c0 0x20>,
<0xff9900e0 0x20>;
reg-names = “local_request_region”,
“local_response_region”,
“remote_request_region”,
“remote_response_region”;
#mbox-cells = <1>;
xlnx,ipi-id = <1>;
};
};

I don’t know if there is more to it than this, there could be if you have a modified PYNQ build for U96…

A simple answer is that the speed of the sd card can make a large difference in how long it takes to install the dpu. It can normally take longer than hour with some cards. I personally use a USB to 1Gbe adapter (to provide the internet connection to the U96) and 128GB Sandisk Extreme Pro card and it takes less than a half hour to install it. If I use slower Delkin or Sony SD cards it takes a lot longer.

Thank you very much, I will replace my sd card to try it.

Hello,I replaced my sd card, but it still didn’t work. How can I find the problem? Can I install the dpu-pynq manually?The image v2.5 that I used is provided by Avnet and I didn’t change it. :pensive:
image

Hi, Just for you I just tried a fresh PYNQ v2.5 image on an Ultra96 and a new install of pynq-dpu. I did not have any issues getting past building the wheels for pynq. Using the fast sd card I mentioned prior it took a minute or 2 and then moved on to the next steps. Again this could take a lot longer if you are using a slower SD card.

I have finished all of the steps. It took about 28 minutes for me to get to installing pynq-dpu (where you said you were stuck) and then that step took about 2 minutes and it completed shortly after. I do see a bit of internet activity during this step. Again I use a USB to Ethernet adapter and I don’t know how my internet speed compares to yours.

I followed the instructions here: https://www.hackster.io/wadulisi/easy-ai-with-python-and-pynq-dd4822

Good luck!

Thank you very much. I think it is the problem of internet speed, and I found that the network is unstable. Luckly I found a image that have update successfully, so I can use it.
But I have another question here: How to build my own overlay for pynq-dpu . If you know the answer, please help me. :grin: