PYNQ: PYTHON PRODUCTIVITY

Ethernet issue, custom board

when I customising the image I had to delete the output folder and then i gave that
make BOARDDIR=test_repo PREBUILT=bionic.arm.2.5.img
output folder created successfully.
But Ethernet is not working.
In my previous project Ethernet is working properly. Now I just add usb driver into it and config the kernel setting for usb. Otherwise I did not change anything. Anything I missed? Why Ethernet is not workning?

2020-04-24_114140
In UART it shows below like this

Please start a new post in the Support section for a new issue. Please try to keep one issue per thread.

For your issue above, is this a new custom image for the same board?

What have you tried to check the Ethernet?
Did you try run ifconfig?

Cathal

yes, I checked the ifconfig
eth0 is not showing
custom image for same board

Without sufficient information to reproduce the problem it’s not possible for us to help you

  1. Using Petalinux with the same settings does the Ethernet device work?
  2. What error messages are you actually seeing when running sudo ifconfig eth0 up
  3. Do you still have the image that worked you can use to compare against - checking the device tree and kernel configuration is a good start.

You are posting many questions and none of hem give us the information we need if we are to give you help. It’s a custom board with a custom BSP - there are many possible non-PYNQ things that could be wrong so just saying it doesn’t work is not helpful in the slightest and will just lead to you being ignored.

Peter

1 Like