PYNQ: PYTHON PRODUCTIVITY

Gov Cloud AWS F1 PYNQ

The Getting Started with PYNQ Alveo Edition Using AWS F1 Instances can be completed in the AWS Gov Cloud Region but the Notebooks do not work. Are the AFIs set up for PYNQ in AWS Gov Cloud?

Can you elaborate on the problem you see?

The examples were note tested on AWS Gov Cloud but the designs should not be locked to any region.

You can query the AFI if you want to check compatibility.

Cathal

The AFIs are not loaded into the Gov Cloud region. I have ran into this issue with another xclbin and Xilinx has put in a support request with AWS to add the respective AFI to those regions.

Would it be possible for the PYNQ project AWS representatives to do the same?

I’l check if we can do this. I’m not sure how long this will take and I don’t have access to this region to test.
It may be faster for you to rebuild the designs yourself?
Cathal

I have tried to create the AFI in my instances (Developer and Vitis AI AMI) but it fails in Vivado when I run the create_vitis_afi.sh (Creating an Amazon FPGA Image (AFI) | XUP Vitis Tutorial).

Looking into the script there is a xclbinutil that I believes fails at --dump-section BITSTREAM:RAW:${timestamp}_SH_CL_routed.dcp

When the dcp is output it is only 22 bytes in size and when the script enters it into Vivado it errors out with ERROR: [Vivado 12-5532] The design checkpoint file failed integrity check (code ‘-1’): /home/builder/checkpoints/SH_CL_routed.dcp

This is with all the xclbins I have tried except the ones that are provided in AWS CL tutorials.

Edit If the request is made to add the AFIs for the gov cloud region I can test the notebooks to verify.

Hi @apodis,

What Vitis and XRT versions are you using?
What design are you rebuilding?
What commit/tag of the aws-fpga repo are you using?

Can you provide the link to the AWS CL tutorials?

Mario