PYNQ: PYTHON PRODUCTIVITY

Install Docker on a ZCU104

Hi everyone.

I"m trying to install Docker on a ZCU104. I followed this instructions. However, I can’t install it due to the absence of packages.

root@pynq:/home/xilinx/jupyter_notebooks# apt-get install \ apt-transport-https \ ca-certificates \ curl \ gnupg
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package  apt-transport-https
E: Unable to locate package  ca-certificates
E: Unable to locate package  curl
E: Unable to locate package  gnupg

This site suggests to edit /etc/apt/sources.list. This file is empty. I tried to follow this solution but adding debian sources to the file creates more errors. What am I supposed to add to sources.list?

Thank you in advance for your help.

Hi @Gwyc,

Which PYNQ image are you using?

The steps to install docker on an Ultra96 are here, and should be the same for ZCU104

Note that docker support was only added on PYNQ v2.6

Mario

I started on DPU-PYNQ/host. It led me to Vitis AI which asked me to install Docker. Back to DPU-PYNQ, I tried to run conda activate vitis-ai-tensorflow and got conda: not found.

I will restart from scratch and hope that everything goes well.

According to what I read in DPU-PYNQ, my understanding is that I have to install Docker on my host machine, install DPU-PYNQ in a container and then install Vitis AI model zoo on top of it in order to be able to recompile new models.

Why would I install Docker on the ZCU104? I thought that the goal was to be able to compile images on a computer and then transfer them to the card.