PYNQ: PYTHON PRODUCTIVITY

KeyError: 'C_Sysref_Master' with RFDC block

Hi Folks,
After updating my ZCU111 2.5 board image with sudo pip3 install --upgrade --upgrade-strategy only-if-needed pynq and importing from pynq.Overlay, xrfdc, and xrfclk.

I’m seeing print(overlayl.ip_dict[‘usp_rf_data_converter_0’]) show xrfdc.RFdcfor the driver, though this only works with ignore_version=True as my block is xilinx.com:ip:usp_rf_data_converter:2.2 and the driver found is for xilinx.com:ip:usp_rf_data_converter:2.1. I’d guess this is because the release was down with 2019.1 and I’ve built my bitstream with 2019.2. Hopefully this isn’t a problem.

The problem I run into is if I try to do rfdc = overlay.usp_rf_data_converter_0. That results in a KeyError

/usr/local/lib/python3.6/dist-packages/xrfdc/config.py in _set_configs(obj, params, config, *args)
113 def _set_configs(obj, params, config, *args):
114 for c in config:
–> 115 setattr(obj, c[0], _to_value(params[c[1].format(*args)], c[2]))
116
117

KeyError: ‘C_Sysref_Master’

Ideas? Do I need to go manually rebuild something from https://github.com/Xilinx/ZCU111-PYNQ

Following along from this post that worked for 2019.1 “resolves” the key error by causing the whole system to hang and need a hard reset.