PYNQ: PYTHON PRODUCTIVITY

Password to log into Pynq (V2.1 image)

I loaded v2.1 image (https://pynq.readthedocs.io/en/v2.2.1/getting_started/pynq_image.html) and boot Pynq-Z1 from it. When connecting to it through network, it asks for password only instead of username AND password. I tried xilinx as in (https://pynq.readthedocs.io/en/latest/getting_started/pynq_z1_setup.html) which didn’t work. What’s the correct way to log in? Thanks.

I’m presuming you mean the Jupyter log in prompt?
Password is xilinx

However, there may be any issue preventing you from logging in.
The board doesn’t have a realtime clock. You are also using an old PYNQ image (we are on v2.5 now).
The system clock is likely to be really far out of date. If you are starting the image for the first time, it could be set to some time around Feb 2018 for that image.
A cookie is set from the board when you try log in. If the date for the cookie is too far away from your system clock on the computer you log in from, it won’t let you in.

Some solutions -
Log in on a terminal, and set the Linux time to something close to up to date. I think that image has a ~30 day limit for cookie.
Some browsers care about this, and others don’t. I think Chrome may be less sensitive to this and may let you log in, but I haven’t checked this in a while.
Plug your board into a router with internet access, and it will update time from an internet server.
Update to v2.5 :slight_smile:

Please let us know if this is your issue, and if it resolves it.

Cathal

You are right :smiley: After logged in, the time showed 2018. Setting up ntp service solved the problem and I was able to log into Jupyter. Anyway, 2.1 is old. I’ll upgrade to 2.5.

Thank you!

1 Like

Hey fiedel, can you please let me know how you logged in to the board?