Petalinux using a version >=2.6 in 2021/2022 tools

I was wondering why there isn’t any meta-pynq layer (PYNQ/sdbuild/boot/meta-pynq at master · Xilinx/PYNQ · GitHub) for Gatesgarth (relative to rel-v2021.1 or rel-v2021.2).

Is there any way I can do that? Tried to change the layer.conf file

LAYERSERIES_COMPAT_pynq = “gatesgarth”

but this fails the build.

Thanks already!

Hi there,

In short, I don’t think there’s an easy way to do that.

The meta-pynq layer moves together with petalinux releases, there’s a handy reference here Going from pynq v2.7 to v3.0 we jump over the 2021 series of tools straight to 2022, so straight from zeus to honister.

You can look at commits on the meta-pynq folder and see what had to be changed as we moved through versions, e.g. this commit updates meta-pynq from zeus to honister meta-pynq updates to Petalinux 2022.1 · Xilinx/PYNQ@5512aff · GitHub (there was a big api update in honister). It can be a tedious process however, so if possible I’d recommend sticking with proven versions of tools for the images.


I am trying to have a pynq-overlay version higher than 2.5.2, which is the default installation on meta-pynq layer by Xilinx (which hasn’t been upgraded…). As the examples based on version >=2.6 are not executed on <=2.5…So I am trying to do this upgrade in a custom-way. (Need to add here that of course I have completed the PYNQ make image for ZCU104 from the sdbuild folder, but this misses basic petalinux-configuration for my ZCU104 board. The final Image when I run XRT can’t find me device at all…)

  1. I tried to install pynq from python -m pip install, on an image produced by petalinux tools both on 2021 and 2022…In various ways, using the pynq_dist.tar.gz (* see at the end what I mean) or by default using the pip pool (using sudo or not). Both ways fail with :

  1. I have imported the meta-pynq layer on petalinux-configuration


and the build fails on both version of Petalinux 2021 and 2022:

I can’t understand why this URL doesn’t work…why it fetches a 2.3 version…and how this URL works when I run the PYNQ makefile on sdbuild folder…

*I can see that inside the PYNQ-image makefile that you are upgrading pynq-overlay with the command