I’m trying to build PYNQ for Ultra96. Here is my setup:
- Ubuntu 18.04.4
- Vitis and PetaLinux 2020.1
- PYNQ and Ultra96-PYNQ repos v2.6.0
After launching the build with make BOARDDIR=(ultra96-pynq repo) it eventually fails with this error message:
ERROR: Cannot install -r requirements.txt (line 28), -r requirements.txt (line 4) and plotly==4.5.2 because these package versions have conflicting dependencies. The conflict is caused by: The user requested plotly==4.5.2 dash 0.21.1 depends on plotly plotly-express 0.3.1 depends on plotly<4.0.0a0 and >=3.10.0 To fix this you could try to: 1. loosen the range of package versions you've specified 2. remove package versions to allow pip attempt to solve the dependency conflict ERROR: ResolutionImpossible: for help visit https://pip.pypa.io/en/latest/user_guide/#fixing-conflicting-dependencies
Anyone know how to get past this?