Port PYNQ 3.01 to new board

I am trying to port PYNQ 3.01 using a ZC702 BSP. After installing Vivado and Petalinux 2022.1 and using the BSP for zc702:

/image_from_prebuilt.sh zc702pynq xilinx-zc702-v2022.1-04191534.bsp arm jammy.arm.3.0.1.gz 
Creating spec file for BSP 
Invoking make
make: *** No rule to make target '/home/dimo /Documents/PYNQ/sdbuild/prebuilt/pynq_rootfs.arm.tar.gz', needed by '/home/dimo /Documents/PYNQ/sdbuild/build/zc702pynq.tar.gz'.  Stop.
Make failed

The same procedure works fine for 2.7 .
Also make BOARDS=pynqz1 does not work either and fails with :

/usr/bin/qemu-arm-static -version | fgrep 5.2.0
make: *** [Makefile:372: qemu_check_arm] Error 1

Any idea what has changed?

This might be an issue in your host’s environment. I would recommend the following things:

  • Start from a clean working directory, do a fresh clone of the PYNQ repository. I’ve noticed that there’s a few cache files that don’t really get cleaned even with the make clean after a PYNQ build.
  • Paste over your board repositories
  • Execute the setup_host.sh script and proceed with the regular sdbuild workflow.

Let me know if you still get the same error after these steps!

@dimiter

See this build example to find the missing puzzle.

Enjoy~