Problem building PYNQ SD image for ZC706

I am using an Ubuntu 18.04.3 LTS VM with Vivado 2019.1 and PetaLinux 2019.1, and I’m trying to build PYNQ 2.5 for the ZC706. It gets all the way to the point where the script is trying to run multistrap, and I get this:

W: GPG error: bionic InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 3B4FE6ACC0B21F32

followed by an error message saying the repository isn’t signed and can’t be updated from securely. I tried adding this key with “sudo apt-key adv …”, and I also tried editing the script and multistrap config file as suggested in this thread:

Neither of these fixes worked for me. Any suggestions would be greatly appreciated…

The error kind of speaks for itself, there’s a missing key.

Please try again adding the key, as documented here and see how far you can get.

Please, as you try again, report out the exact steps you performed so we can understand a little more what is going on.

As I mentioned in my post, I did add the key. This is the command I used:

sudo apt-key adv --keyserver --recv-keys 3B4FE6ACC0B21F32

which is the same as what is in the link you sent. I had this command line in my original post, but the website wouldn’t let me post it. It saw “” as a link and said I was trying to post too many links as a new user…

One thing you might try is to avoid this step altogether when building for your board.
The way you do it is by passing our pre-built rootfs.
You can download it here, under “other boards”. For the aarch64 architecture is this image.
Once downloaded, you can pass the PREBUILT arg to the make command, like this:
make PREBUILT=<full-path-to-rootfs-img> ...
This will avoid the step where you are having troubles, and in the end, will also be tremendously faster.
Besides, this is also the reccommended/supported way of building images for other boards. You should avoid rebuilding the rootfs yourself unless you strictly need it because you made modifications to it (which I assume is not your case).

I am sorry I can’t be of more help

1 Like

Using the prebuilt rootfs got me over this hurdle. Thanks for the help!

I was following the instructions here, which do not mention the PREBUILT arg.

You are right, it’s not really documented. Thanks for the feedback! And glad I was able to help!

Hi @JTC, I just wanted to give you an heads up on this matter. We took your feedback and updated the documentation, along with other build flow improvements, with this pull request

The readthedocs change is not yet visible on the website, but it will be up in the next docs update.
Again, many thanks for providing feedback, we truly appreciate the help from the community!

1 Like

Hi @gnatale,
I am facing the same problem.
After using make PREBUILT= … I am still getting the error

W: GPG error: bionic InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 3B4FE6ACC0B21F32

The image is generated by a message failed to generate image.img is displayed.
I am just trying to rebuild PYNQ-Z2 and after I would try to retarget to a Zybo Z7-20.

Could you please help?
Thank you

Hi, please ask questions in one thread - it will be checked and answered.

1 Like

Sorry @rock, I will follow the other thread.