Problem with .hwh parsing

I have recreated the following project for my PYNQ Z1 device (I have tried v 2.4 v 2.5 and v2.6 images). I originally used Vivado 2020.1 for this project but I also tried with 2019.1 (and image v2.6) and the issue persists.
Link to the project: PYNQ-HLS/4-Using-an-HLS-core-in-PYNQ.ipynb at 60cfd98362632ea4417309a3d73ff60885eba1ab · drichmond/PYNQ-HLS · GitHub

However, when I load the overlay I get the AttributeError: ‘NoneType’ object has no attribute ‘get’ error. I have copied the complete error message at the end of this post.

I have tried the same thing with the .hwh + .bit files in the overlay folder. I have also tried with .hwh + .bit + .tlc (assuming that if it needs something that it can also find in the tlc file) but I keep getting the same error.

I also came across another post with the same error but I don’t make the mistake that the individual in that post was making with respect to the .tlc file. So I cannot think of anything else that I might be doing wrong.

Complete error message:

AttributeError Traceback (most recent call last)
in ()
----> 2 overlay = Overlay(’/home/xilinx/pynq/overlays/mmult_test/mmult.bit’)

/usr/local/lib/python3.6/dist-packages/pynq/ in init(self, bitfile_name, download, ignore_version)
292 tcl_path = get_tcl_name(self.bitfile_name)
293 if os.path.exists(hwh_path):
–> 294 self.parser = HWH(hwh_path)
295 elif os.path.exists(tcl_path):
296 self.parser = TCL(tcl_path)

/usr/local/lib/python3.6/dist-packages/pynq/ in init(self, hwh_name)
807 self.match_ports()
808 self.match_pins()
–> 809 self.add_gpio()
810 self.init_interrupts()
811 self.init_hierachy_dict()

/usr/local/lib/python3.6/dist-packages/pynq/ in add_gpio(self)
1009 self.ps_name, self.family_gpio))
1010 if mod is not None:
-> 1011 din = int(mod.find(".//*[@NAME=‘DIN_FROM’]").get(‘VALUE’))
1012 for p in mod.iter(“PORT”):
1013 if p.get(‘DIR’) == ‘O’:

AttributeError: ‘NoneType’ object has no attribute ‘get’

Here’s an image of what I am doing:

Did you solve this issue?
I’m getting the same error for my design.

Edit: I’m using the PYNQ-Z2 with the v2.6 image, and Vivado 2020.1 on Ubuntu 18.04

Could you post this as a new issue please (and provide your source files)?

Thanks for the reply. Posted it here.

Sorry for late reply. If this is still a problem, can you post your HWH?