Pynq 3.0 fails quemu version check

Installed pynq 3.0 on an Ubuntu 20.04 with Xilinx tools 22.1


Went to /sdbuild and typed make. Result:

/usr/bin/qemu-aarch64-static -version | fgrep 5.2.0
make: *** [Makefile:372: qemu_check_aarch64] Error 1

checked the qemu version:

qemu-aarch64-static -version
qemu-aarch64 version 4.2.1 (Debian 1:4.2-3ubuntu6.23)
Copyright (c) 2003-2019 Fabrice Bellard and the QEMU Project developers

What’s the problem?

Hi there,

Does the ~/.profile file exist in your home directory? It gets created at the tail end of the setup_host script.

Launch a bash terminal with bash -l and see if which qemu-aarch64-static returns the executable in the /opt path.

You could also try to manually export the paths with export PATH=/opt/qemu/bin:/opt/crosstool-ng/bin:$PATH.


Yep, there is a .profile file

which qemu-aarch64-static 

for the time being I changed the makefile to the current qemu version (4.2.1) but then fails finding ct-ng

/usr/bin/qemu-aarch64-static -version | fgrep 4.2.1
qemu-aarch64 version 4.2.1 (Debian 1:4.2-3ubuntu6.23)
/usr/bin/qemu-arm-static -version | fgrep 4.2.1
qemu-arm version 4.2.1 (Debian 1:4.2-3ubuntu6.23)
vivado -version | fgrep 2022.1
Vivado v2022.1 (64-bit)
vitis -version | fgrep 2022.1
****** Vitis v2022.1 (64-bit)
which petalinux-config
which arm-linux-gnueabihf-gcc
which microblaze-xilinx-elf-gcc
which ct-ng
make: *** [Makefile:410: checkenv] Error 1

Yes, I ran

After a manual install of crosstool-ng (1.25) started running…

With mostly these two actions I could build the included board images.

So questions are:

Which qemu version expects Pynq 3.0?

Does the setup install ct-ng (or did it fail for whatever reason on my side)?

The setup_host script installs them in /opt/qemu (version 5.2.0) and /opt/crosstool-ng. If they are not there something must have went wrong with the setup. Did you try my 2nd suggestion of including those directories in your path?


Both crosstools-ng and qemu were installed in /opt/
Adding the paths to PATH solved that problem