Pynq installation on Kria KV260 with Ubuntu 22.04 LTS - help please

Hi,

I tried to install Pynq on a Kria KV260 loaded with the Ubuntu 22.04 version. I’ve tried to modify the install.sh script by changing the version of some packages (python3.10-venv for instance instead of python3.8-venv) to get past errors. So far I have reached a point where I am able to get Jupyter Lab running but still a dismal failure on my part.

Will there be an install script to cater for Ubuntu 22.04?

Thank you

Can you paste a screenshot of the errors that you get after running your modified install.sh?

Hi, thank you for your interest.

This is the first mod:

the python3.8-venv has been replaced with python3.10-venv because it will say that the version 3.8 cannot be found.

The next error is this:

To fix this I actually placed a folder pynq/sdbuild/packages/python_packages_focal which I copied from a running version of Pynq where the os is Ubuntu 20.04 LTS. That made this script go further through the process. I will send the next set of errors.

Erg

Here is another error:

To fix this, I went to the file /home/ubuntu/Kria-PYNQ/pynq/sdbuild/packages/python_packages_focal/qemu.sh

In that file, I commented out the line pkg_resources==0.0.0

This allowed me to move a bit further on the install process.

Erg

I gave up after this error while building NumPy:

I can’t sent the rest as it is a long long list of messages.

Erg

And after fixing the error above by changing the NumPy version to numpy==1.23.2

I stopped after this error that I could not figure out how to fix:

Hi @erg900,

The Ubuntu 22.04 is a pre-production release. So, we have not ported the installation scrip to it yet.
Any particular reason you want to use 22.04 and not 20.04?

Mario

Hi Mario,

No particular reason. I thought was going to be an easy journey but I’m wrong with that assumption. I’ll be keen to go and use the new script when it becomes available. Thanks for the message.

Erg

Hi @erg900,

When the Ubuntu 22.04 production image is launched, we will start with the porting process.
In the meantime, I think the best thing is to use the 20.04 image.

Mario