PYNQ on ZCU208: Juypter notebook kernel disconnects often


I’m running PYNQ v3.0.1 on ZCU208 board. While running the base overlay (“Loop-back test”: the kernel keeps disconnecting at a particular line in the code (please see the attached figure). I tried changing the micro USB cable connection to my PC but the problem persists.

Once I loose the connection, I had to manually restart the board in order to run anything on it. Otherwise, I can’t connect or execute any command.

I also checked similar error posted in Problem with Disconnects in Jupyter but didn’t solve my problem.

Thanks for your help!

kind regards,

1 Like

SD cards can be unreliable. I’d suggest you try to burn a new image onto a different SD card.


1 Like

Thank you Cathal!

I’ve already tried with different SD cards (with 16GB and also 32GB) the outcome is the same. I managed to run simple setups like FIR filtering and FFT without any issue. Do you think it might be related to memory since the base overlay for loop back test is a bit complicated?

I’m using SanDisk Ultra 32GB SD card, do you any recommendation which kind of SD card to use?


1 Like

Please help! I’m stuck, couldn’t be able to find any way around this issue.


(I didn’t see your other reply about SD cards. I don’t recommend any in particular.)

Can you try connect a USB terminal to check if there are any error messages printed when this line of code fails?
Can you also check if the board is completely locked up or if the OS is still running? i.e. try run any simple Linux command on the terminal.


1 Like

Hi Cathl,

Thanks again for getting back to me!

Nothing is printed out in the terminal when the connection stalls… the terminal also freeze.

The board seems to be completely locked up, I can’t type any command on the terminal. I have to manually power off and then power on the board to regain access.

In addition, some times the after restart of the board I notice that the Status LED, DS2 PS_INIT_B, stays RED (FPGA initialization is in progress) and doesn’t turn GREEN (see attached picture


1 Like

Hi @cathalmccabe,

Could you please have a look on my previous reply to your questions?



The problem is now solved! The reason was, the SMP clock cables from the CLK104 to the RFSoC were not connected. When operating at higher sampling rates (clock rates) in the RF Data Converter it is recommend to use the clock generated by the CLK104 instead of the system clock from the RFSoC. After connecting the clock cables everything works as expected.


1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.