PYNQ: PYTHON PRODUCTIVITY

Problem with Disconnects in Jupyter

When working with Jupyter notebooks, I often get Kernel Disconnect, even with very simple notebooks with very little compute. I’ve attached a screenshot of what it looks like. I’ve turned off firewall, used different browsers, etc. I’m sure the problem is not insufficient resources. The same code block can sometimes take a long time while completing instantly at other times. The javascript console also doesn’t really give any useful errors.

There is also a problem with terminal instances becoming totally frozen when inputting too fast. Pretty reproducible. This is on Ultra96v2 with Pynq2.5. Is there any particular reason this is the case? Do other Ultra96v2 users experience this, or do I have defected hardware? I’ve tried with the included delkin card and also with another samsung card I got (fastest one I could find on the market), and the problem presists.

Any help would be greatly appreciated, it is really quite frustrating. Thanks in advance folks.

This is not typical behavior. PYNQ v2.5 for Ultra96 was released over a year ago and has not had any known major issues.

How are you connecting your PC to the Ultra96 ? If using the USB cable can you try another cable? Also, you could try a USB to Ethernet adapter and connect the U96 to a LAN and access it from your PC through Ethernet as well. If the Ethernet works then it is likely either the the cable, the USB connectors or your PC. If the Ethernet doesn’t work also, it might be a defective U96 board but that still doesn’t absolutely prove it.

Kind regards

1 Like

Right now I’m connecting through the on-board micro USB port. However, using a different USB cable appears to have almost entirely fixed the issue…

I’m not sure why the other cable has problems, it was a pretty fancy one. Regardless, thanks for the help. It seems to be solved for now.