PYNQ: PYTHON PRODUCTIVITY FOR ZYNQ

Python IDE on ZCU111

I would like to set up a Python IDE on the ZCU111 to support software development. I am on Xilinx Release 2019_06_26 d9c7521, I have PYNQ installed and have run several of the Jupyter notebooks successfully.

Probably I am having difficulties because I am fairly new to both Python and Linux.

I have tried to install IDLE, which comes with the Linux distribution, but it seems to want to connect to the Internet during installation, and I haven’t sorted out how to do that given that I am connected to the ZCU111 from my laptop over an Ethernet cable.

I tried Spyder, but the Anaconda installation seems to think the ZCU111 is 32 bits (the Linux lscpu command confirms that it is not) and then generates an install error.

I have got PyCharm (Community) installed, following

and

https://www.jetbrains.com/help/pycharm/installation-guide.html#linux

Using the ‘Install using tar achives’ steps, since we don’t seem to have snap.

So far so good. But then

sh pycharm.sh

Generates

Error: Can’t open display:

Which I hope is a relatively simple configuration problem. Is there anyone smarter than me about this that can set me straight?

Thanks,
Jerrold

I use pycharm as well, but I usually just open the file from samba drive, and use pycharm like a text editor. For samba access, you should be able to map your board into your PC. See here:https://pynq.readthedocs.io/en/latest/getting_started.html#accessing-files-on-the-board

1 Like