PYNQ: PYTHON PRODUCTIVITY

Question about Ubuntu Versions

Hi,

I understand that we can choose Ubuntu 16.04 or 18.04 to build the PYNQ image. However, aren’t we limited with what version PetaLinux 's supported OS. For an example, I used a Ubuntu 18.04, and installed PetaLinux 2018.3, but this version of PetaLinux is only supported by Ubuntu 16.04. The way I know this is by checking it’s documentation.

Does this mean, that I have to use Ubuntu 16.04 version if I want to use a Xilinx tools version of 2018.3?

Yes. We started the SD build with ubuntu 16 because that was the only supported ubuntu OS by petalinux at that time. I think later versions of Xilinx tools have better support like ubuntu 18. So for your case, I think it might be safer to use ubuntu 16.

1 Like