RFSoC 4x2 Does not show any IP address in the Display

Hello @marioruiz,

I have purchased the PYNQ RFSoC 4x2 development board. I am having issues with setting up the board.
I have attached an image of the board connection setup and microSD card contents.
These are the steps I followed to connect the board:

  1. Updated the PYNQ images to the latest version in the microSD card.
  2. Plugged in the microSD card.
  3. Set up the boot button to SD mode
  4. Connected power cable (power adapter)
  5. Used the USB cable to connect UART port on the board to the USB port on the host PC.
  6. Finally, I have an USB-to-ethernet adapter. Connected the ethernet port on the board to one end of the ethernet cable and the other end of the ethernet cable to the USB-to-ethernet adapter.
    My PC is connected to the internet through ethernet port.
    I have set the IP address of the board as ( using the USB-to-ethernet adapter which pops up in the network settings.
    The mini display does not show any IP Address.
    The “init” and “done” leds do not turn green.
    I have also attached the screenshot of the microSD contents.
    PYNQ Images

Any immediate help would be highly appreciated.
Thank you

PYNQ Images

1 Like

Do you see any output from the UART terminal?


Hi there,

Would be good to know if anything is showing up in the UART terminal as Cathal said.

In addition to that, could you clarify your first step “Updated the PYNQ images to the latest version”, did you burn a new SD card image from PYNQ - Python productivity for Zynq - Board?

Also, just making sure, are you using the power supply that came with the box?


Hello @cathalmccabe

Thank you for your response.
It would be great if you could give a hint which output you are referring to.
I have connects the other end of the USB to the PC.

Thank you

Hello @skalade
Thank you for your response.
Yes I have downloaded the latest image file from the link you mentioned for RFSoC 4x2 v3.1.

Yes I am using the power adapted shipped with the board. I am using everything shipped with the board.

Thank you

The USB cable connected to PROG UART will give you a terminal.
You can open a terminal (find the com port on your computer, and set Baud: 115200).
Check if you see any output on the terminal as the board boots.


I see. I have opened a terminal using “Putty”. Below are the screenshot images of the terminal setup and its output.
Putty Terminal
Putty Terminal_2
Terminal Output

Thank you


I updated the microSD card and the LCD display now works. The issue is every time I make any connection changes I have to push/pull the microSD card to the slot and then it works.

However, now the problem is the LCD displays “No IP detected”.
I have taken out one ethernet connection from an ethernet switch and connected it to the board. The PC is connected to the same same ethernet switch,

Please find the attached screenshot of the board condition. Looking forward to any immediate help.

Thank you

You shouldn’t have to take the SD card out unless you have made changes to the image/need to reflash the image. Power cycling the board (switching the power switch on/off) is what you want to do to reset your board if you made a new connection that maybe hasn’t been picked up.

If the board boots and everything else works then this sounds like a general networking issue. You should be able to connect to a serial terminal, as Cathal described earlier, and do some debugging… Type ifconfig to see if there’s an IP address that got assigned after boot perhaps.
Try searching this forum and others, there are many posts like this one PYNQ-2.7 on ZCU104 has network connection problem discussing networking issues.

You could try using the microUSB connection with usbgadget and connect directly to your computer as outlined in the rfsoc4x2 getting started page Getting started with your RFSoC 4x2 | RFSoC-PYNQ.


1 Like

Hello there,

I have finally resolved the problem. Steps to follow to have network access to the RFSoC 4x2 board:

  1. Go the network settings of your host PC
  2. Go to the “Sharing tab” in the “change adapter options” section
  3. Check the two boxes mentioning to allow sharing of the ethernet connection over the network. This allows any external devices (RFSoC 4x2 in this case) connected to your host PC to have internet access.
  4. Then assign a static IP to the “Ethernet” option in your network settings (Realtek USB GbE Family controller in my case since I am using USB to ethernet adapter)
  5. Boot the board and you are all set.

Thank you @cathalmccabe and @skalade for your valuable suggestions.


1 Like