No IP detected rfsoc 4x2

I’m trying to connect to rfsoc 4x2 board. I flashed the SD card with the latest version of the image file. After the board boots, the message “no IP detected” is shown on the OLED.

I tried the steps mentioned here and set the static IP address to “”. However, It did not work.

I also tried to connect to the board via serial, but my PC does not recognize the board with the 43 error code.

Any help would be highly appreciated.
Thank you

How have you connected the board to your network or to your PC?
What is the “43 error code”? Can you provide the full message?


Thanks for your answer. I connected the board directly to my PC.

The error message is “windows has stopped this device because it has reported problems. (code 43) USB”. I was wondering if I should install any particular drivers.

Can you confirm you used a USB cable to do this and connected it to the USB Composite port? I’d suggest you try with a spare USB cable if you have one.
You should not need to install drivers, but this may depend on your computer/OS. Which version of Windows are you using?


Steps that you can try to connect the board to the network:

  1. Try to flash the SD card again with the latest PYNQ images (v3.0.1 for my board)
    PYNQ - Python productivity for Zynq - Board
  2. You have to give permission to external devices to share the network by following the steps here

Best Regards,

Hi Kefayat,
Thanks for your answer. I changed the IP to, and now it is working.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.